Standard Approach of Modelling (SAM)
For Creating Building Information Structural model
for
Development and Construction Division of
Hong Kong Housing Authority

(First Edition)
March 2014

Prepared by Business Information Technology Unit
Development & Construction Division
Housing Department

©Hong Kong Housing Authority
The Government of the Hong Kong Special Administrative Region
Introduction

The aim of this document is to establish a standard approach of modelling (SAM) for assembling Building Information Modelling (BIM) models with the incorporation of structural design concept. Through the SAM, the resulting BIM model can facilitate cross-disciplinary coordination and collaboration at design and drawings production stages (including plans, sections and elevations). It also serves as a guide for creating BIM model which is ready for exporting to other structural analytical/design software when the data interlinking process becomes mature and practical.

This standard approach has incorporated some modelling technique to facilitate quantities extraction from the BIM model. Due to the constraints of current version of BIM software, the quantities extracted from BIM model can only be served as references, quantity surveyors have to execute their professional judgment and make necessary adjustments before using the data.

This version of SAM involves reinforced concrete elements of superstructure only and Autodesk Revit Structure has been the modelling tools throughout this document. It is assumed that users shall possess structural engineering knowledge and Revit Structure modelling skill when using this guide.

It is advisable that all Revit models shall start with the using of Housing Authority (HA) Revit Structure project templates, the component library and shared parameters files developed by BIM Service Team (BIMST). The latest version of these files can be obtained from BIMST on request. This document shall also be read in conjunction with other BIM Standards / Guides issued by BIMST which are available for download from e-housing portal with the path as below.

e-housing > DC > Main > Main Page > Building Information Modelling (BIM)

The Annexes attached in this modelling guide contain some examples of BIM models with explanatory notes to provide users with a quick step-by-step guide for carrying out their modelling tasks. Colleagues may obtain more modelling skills and tips in the HA Knowledge Management portal through the following path.
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. General Principles</td>
<td>1</td>
</tr>
<tr>
<td>2. Level of Detail</td>
<td>6</td>
</tr>
<tr>
<td>3. Modelling of Structural Elements and Components</td>
<td>7</td>
</tr>
<tr>
<td>3.1 Columns / Posts / Hangers</td>
<td>8</td>
</tr>
<tr>
<td>3.1.1 Modelling approach</td>
<td>8</td>
</tr>
<tr>
<td>3.1.2 Family Customization</td>
<td>10</td>
</tr>
<tr>
<td>3.2 Shear / Core / Bearing / Hanger / Stub / Screen Walls and Parapets</td>
<td>12</td>
</tr>
<tr>
<td>3.2.1 Modelling approach</td>
<td>12</td>
</tr>
<tr>
<td>3.2.2 Family Customization</td>
<td>16</td>
</tr>
<tr>
<td>3.3 Beams</td>
<td>17</td>
</tr>
<tr>
<td>3.3.1 Modelling approach</td>
<td>17</td>
</tr>
<tr>
<td>3.3.2 Family Customization</td>
<td>19</td>
</tr>
<tr>
<td>3.4 Ground Beams</td>
<td>21</td>
</tr>
<tr>
<td>3.4.1 Modelling approach</td>
<td>21</td>
</tr>
<tr>
<td>3.4.2 Family Customization</td>
<td>21</td>
</tr>
<tr>
<td>3.5 Suspended Slabs and Transfer Structures</td>
<td>22</td>
</tr>
<tr>
<td>3.5.1 Modelling approach</td>
<td>22</td>
</tr>
<tr>
<td>3.5.2 Family Customization</td>
<td>24</td>
</tr>
<tr>
<td>3.6 On-Grade Slabs / Floating Slabs / Machine Bases / Pile Caps/Raft Footings</td>
<td>25</td>
</tr>
<tr>
<td>3.6.1 Modelling approach</td>
<td>25</td>
</tr>
<tr>
<td>3.6.2 Family Customization</td>
<td>25</td>
</tr>
<tr>
<td>3.7 Staircases</td>
<td>27</td>
</tr>
<tr>
<td>3.7.1 Modelling approach</td>
<td>27</td>
</tr>
<tr>
<td>3.7.2 Family Customization</td>
<td>28</td>
</tr>
<tr>
<td>3.8 Water Tanks</td>
<td>29</td>
</tr>
<tr>
<td>3.8.1 Modelling approach</td>
<td>29</td>
</tr>
<tr>
<td>3.9 Precast Façades (non-structural)</td>
<td>31</td>
</tr>
<tr>
<td>3.9.1 Modelling approach</td>
<td>31</td>
</tr>
<tr>
<td>3.9.2 Family Customization</td>
<td>31</td>
</tr>
<tr>
<td>3.10 Plinths / Mass Fills / Curbs / Fillets</td>
<td>33</td>
</tr>
<tr>
<td>3.10.1 Modelling approach</td>
<td>33</td>
</tr>
<tr>
<td>4. Notes for Family, In-place Model and Sub-Model</td>
<td>34</td>
</tr>
<tr>
<td>4.1 Comparison between family, in-place Model and sub-model</td>
<td>34</td>
</tr>
<tr>
<td>4.2 Generic Family</td>
<td>34</td>
</tr>
</tbody>
</table>
5 Model Auditing.................................................................................................................. 35

Annexes.................................................................................................................................. 41
1 General Principles

The followings are the general principles should be adopted when assembling a Building Information Structure Model (BIM Structural model):

i) All BIM Structure Model should contain structural elements shown on the framing plans only. Other building elements are assumed containing in other discipline BIM models.

ii) The following elements are to be excluded from general BIM structural model:
   a. Non-structural building elements.
   b. Reinforcement bars.
   c. Elements / details shown in the typical details drawings only but not in any other plans and sections including lift lips and column shoulder for beam with different grade of concrete… etc.
   d. Elements / details shown on plan for indication purpose only, their detail dimensions and locations / distribution have to be referred to other discipline drawings. For instances, wall cowl, lift lips and fluted concrete of architectural feature.
   e. Detail arrangement of semi-precast slabs in standard modular flat.

iii) A building or even a project model is advised to be divided into a number of sub-models. By doing so,
   a. a building model or even the whole project model can be worked out simultaneously by group of modelers;
   b. as there is no need to handle large model during modelling stage, the demand on computer hardware configuration can be greatly reduced.

iv) The following rules can be considered when determining the way to divide a project model.
   a. The sub-model can be used repeatedly in a project such as typical floor.
   b. Separated structure (such as multi-towers on a common podium, multi-blocks in a site or podium separated by an expansion joint).

v) For facilitating the linking of individual sub-models to a building model at
the later stages, modeler should adopt the following practices when making the sub-models.

a. The locations and orientations of all sub-models should refer to the same origin.

b. All sub-models should be built at the levels according to project design.

c. Select “Auto – Origin to Origin” for Positioning during the linking sub-model process

![Image of Import/Link RVT dialog.](image)

Figure 2.1 Import/Link RVT dialog.

vi) All building should be modeled storey by storey. Each storey model is an assembly of the structural floor system and its vertical supporting structural elements together with the precast facades below the floor level and the minor structural elements like parapets and plinths are attached on top of the floor system.

vii) Storey models with same layout but with different concrete grade should be saved as two distinct sub-models assigned with appropriate materials.
vii) The advised sequences to assemble a storey model are advised as below:

Columns/Walls → Main Beams → Secondary Beams → Slab → Parapets / Plinth / Mass Fill

ix) Appropriate families should be applied to model different structural elements. The table below defines the convention that need to be followed during modelling process.

<table>
<thead>
<tr>
<th>Structural Elements</th>
<th>Revit Family Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columns, posts and hangers</td>
<td>Structural Columns</td>
</tr>
<tr>
<td>Shear wall, core walls, bearing wall, hanger walls, stud walls, screen wall and parapets</td>
<td>Walls (Structural Wall type)</td>
</tr>
<tr>
<td>Beams and lintels</td>
<td>Structural Framing or Structural Beam Systems</td>
</tr>
<tr>
<td>Suspended slabs, transfer plates or beams, and staircase landings</td>
<td>Floors (Structural Floor type)</td>
</tr>
<tr>
<td>On-grade slabs and mechanical plant bases</td>
<td>Structural Foundations (Foundation Slab type)</td>
</tr>
<tr>
<td>Caps, footings and piles</td>
<td>Structural Foundations</td>
</tr>
<tr>
<td>Stair flights</td>
<td>Stairs</td>
</tr>
<tr>
<td>Other elements e.g. plinths, mass fills, fillets and curb...etc</td>
<td>Generic Models (In-Place)</td>
</tr>
</tbody>
</table>

x) A structural model should be assembled according to the following rules:

a. each structural element should be modeled individually;
b. structural behavior of elements is incorporated.
xi) As a result, all horizontal and inclined elements should be connected on the center line (actually the family reference plane) of their support elements instead of the edges.

xii) Revit treats beam as prismatic object and supported at its ends only. So, all transfer structures should be modeled with Structural Floor elements in order to cater for the complicated support conditions and the vertical elements carried by them.

xiii) All elements should be specified with the designed construction material (i.e. concrete for reinforced concrete structure). The material applied should be customized with appropriate mechanical properties to the prevalent Code of Practice. The modeler should also use with those materials that their names can reflect the intended construction method. Examples for concrete material are as follow:

<table>
<thead>
<tr>
<th>Construction Method</th>
<th>Conc. Grade</th>
<th>Material Name in Revit</th>
</tr>
</thead>
<tbody>
<tr>
<td>In-situ</td>
<td>C30/20</td>
<td>HD_In-Situ Conc.C30/20</td>
</tr>
<tr>
<td></td>
<td>C45/20</td>
<td>HD_In-Situ Conc.C45/20</td>
</tr>
<tr>
<td>Precast</td>
<td>C35/20</td>
<td>HD_Precast Conc.C35/20</td>
</tr>
<tr>
<td></td>
<td>C40/20</td>
<td>HD_Precast Conc.C40/20</td>
</tr>
<tr>
<td>Precast (Embedded into In-situ conc.)</td>
<td>C35/20</td>
<td>HD_Precast Conc.(Embedded)C35/20</td>
</tr>
<tr>
<td></td>
<td>C40/20</td>
<td>HD_Precast Conc.(Embedded)C40/20</td>
</tr>
<tr>
<td>Semi-precast</td>
<td>C30/20</td>
<td>HD_Semi-Precast Conc.C30/20</td>
</tr>
<tr>
<td></td>
<td>C40/20</td>
<td>HD_Semi-Precast Conc.C40/20</td>
</tr>
<tr>
<td>Volumetric precast</td>
<td>C30/20</td>
<td>HD_Vol. Precast Conc.C30/20</td>
</tr>
</tbody>
</table>

xiv) All customized standards within a project template and families (or family types in case of system family) should provide with names start with “HD_” so that they can be differentiated from the default ones.

xv) All families (except precast elements) should include data such as material type, material volume, surface area and basic dimensions which can be extracted for material takeoff purpose.
xvi) New families to be submitted to HA BIM library should accompany with an explanatory note. The note should include:

a. The category it belonged to;
b. Description of its application;
c. Components included and method used to create them;
d. Meaning of each parameter used;
e. Application step guide;
f. Limitations and points to note of the family; and

g. The way to extract data for material quantities takeoff.

xvii) It is advised that every structural element should be assigned with a *Mark* or and a descriptive *Comment* to their properties so that cross-discipline collaboration process can be more effective.

xviii) For framing plans production, the *Detail Level* and *Visual Style* of all plan views should set to “Coarse” and “Hidden Line” respectively.

![Visual Control Panel of Revit](image)

(a) Options of Details Level  
(b) Options of Visual Style

Figure 2.3 Visual Control Panel of Revit
2 Level of Detail

All BIM model can be developed stage by stage. The level of detail within a model required is decided to suit the need of different project stages.

<table>
<thead>
<tr>
<th>Project Stages</th>
<th>Level of Detail</th>
</tr>
</thead>
<tbody>
<tr>
<td>Submission:</td>
<td></td>
</tr>
<tr>
<td>• Architectural Advisory Panel;</td>
<td></td>
</tr>
<tr>
<td>• Engineering Advisory Panel;</td>
<td></td>
</tr>
<tr>
<td>• Project Design Review Committee (1);</td>
<td></td>
</tr>
<tr>
<td>• Senior Office Management Committee;</td>
<td></td>
</tr>
<tr>
<td>and Steering Project Committee.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>No model except for special site.</td>
</tr>
<tr>
<td>Submission:</td>
<td></td>
</tr>
<tr>
<td>• Project Design Review Committee (2); and</td>
<td></td>
</tr>
<tr>
<td>• Building Committee.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>No Model except for special site.</td>
</tr>
<tr>
<td>Submission:</td>
<td></td>
</tr>
<tr>
<td>• Detail Design Review Panel (1) &amp; (2)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DDRP 1 – full model for analysis as appropriate.</td>
</tr>
<tr>
<td></td>
<td>DDRP 2 – full model for project collaboration.</td>
</tr>
<tr>
<td>Submission:</td>
<td></td>
</tr>
<tr>
<td>Independent Checking Unit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Full model for</td>
</tr>
<tr>
<td></td>
<td>• analysis as appropriate;</td>
</tr>
<tr>
<td></td>
<td>• project collaboration;</td>
</tr>
<tr>
<td></td>
<td>• drawing production i.e. fully annotated</td>
</tr>
<tr>
<td>Tender-Out</td>
<td>Ditto</td>
</tr>
<tr>
<td>Construction</td>
<td>As-built model provided by Contractor</td>
</tr>
<tr>
<td>Maintenance</td>
<td>Ditto</td>
</tr>
</tbody>
</table>
3 Modelling of Structural Elements and Components

The following sub-sections describe the standard modelling approach for major structural elements of a BIM structural model. Notes for family customization and necessary parameters are also advised in the corresponding sub-sections.
3.1 Columns / Posts / Hangers

3.1.1 Modelling approach

i) All columns / post / hanger should be modeled with appropriate Structural Column category family elements selected according to their sectional shape. For those elements not to be included into the building structure analytical model, modeler should set the element instance property Analyze As to “Not for analysis”.

![Figure 3.1.1 Column Properties palettes](image1)

![Figure 3.1.2 Column elements](image2)

ii) All columns should be defined between the levels where they serve as support for other elements and top of their supporting elements (like top of the column / wall / beam and foundation below), with required level offsets.

![Figure 3.1.3 Post and hanger posts](image3)
iii) A descriptive Comments like “Hanger post” and “Post” is advised to be added to the Comment properties for those elements which are not used as normal columns.

![Figure 3.1.4 Column Properties palette](image)

iv) Irregular shape column should be modeled according to the design assumptions:

a. The whole irregular shape column is adopted for structural design:

   The corresponding column family for the irregular shape column should be used.

b. Only the regular part with the column is adopted for structural design:

   A regular shape column family is chosen for the column. In-Place model(s) under Structural Columns family category is/are used to model the rest of the column.

![Figure 3.1.5 Modelling of irregular column](image)

The In-Place model should be provided with a family name like “Mass Fill for Column C5” so that it can be recognized as parts of that particular column. Similar description is also advised to be added to the Comments field of its Properties palette.
3.1.2 Family Customization: Structural Column (Loadable Family)

i) The reference planes “Centre (Front/Back)” and “Centre (Left/Right)” predefined in Revit Structural Column family template should cut across the column section and locate at the mid-point of the overall dimensions perpendicular to them.

ii) All Column Family should provide with suitable sharable parameters such that their geometry data can be retrieved for other model users.

iii) For rectangular and circular column Families, the following sharable parameters have to be added for facilitating quantities takeoff:

   **Column Width** (for rectangular column);
   **Column Depth** (for rectangular column);
   **Column Dia** (for circular column);

iv) Column size has to be entered into the **Description** field for annotation purpose.
v) All vertical faces should be painted with material, name as “Column Side Formwork”, so that the area of column formworks can be estimated.
3.2 Shear / Core / Bearing / Hanger / Stub / Screen Walls and Parapets

3.2.1 Modelling approach

i) All structural walls should be modeled with appropriate types from Basic Wall category family with its Structural Usage property set to “Bearing”. It can be achieved by selecting Revit ribbon, Home tag ➤ Structure panel ➤ Wall dropdown list ➤ Structural Wall when creating a wall.

![Wall Properties palette](image1)

(1) Wall Properties palette (2) Creating structural wall by selecting the corresponding command from Revit ribbon

Figure 3.2.1 Modelling of structural wall

ii) For those elements not to be included in analytical model, modeler should unchecked the element property Enable Analytical Model check box.

![Properties palette of wall](image2)

Figure 3.2.2 Properties palette of wall

iii) All walls should be defined with Top and Base Constraints between the levels where they serve as support for other elements and top of their supporting elements. Level offsets can be applied as appropriate. The top level of walls should be extended to top of slabs being supported instead of to the soffits of slab elements only.
iv) Descriptions like “Hanger wall” and “Bearing wall” are required to be added to the Comments properties of wall such that their structural usage can be identified.

v) For irregular shape wall, modeler may consider such wall as a composition of a regular wall panel with concrete fills for the rest of the wall when the irregular parts are excluded from structural design. In this case, the concrete fill part can be modeled as an In-Place model under Walls category.
The In-Place model should be provided with a family name like “Mass Fill for Wall W1” so that it can be recognized as the mass fill for that particular wall. Similar description is also advised to be added to the Comments field of its Properties palette.

vi) Parapet Walls

Both **Top Level** and **Base Level** of parapet walls should be assigned with identical level together with the **Top Offset** made equal to the required parapet height.

Parapet wall should be included into the storey model in which the parapet wall is attached.
For parapet walls with piers, they should be modeled as individual wall spanned between piers edge

The pier should be modeled with structural column family element. Their **Analyze As** property should be set to “Not for analysis” and a description “Parapet Pier” added to the **Comment** property of the element, sub-section 3.1 refers. Similar to the parapet wall, both Top Level and Base Level of piers should be assigned with identical level together with the Top Offset made equal to the required parapet height.

![Parapet wall with piers](image)

**Figure 3.2.9  Parapet wall with piers**

vii) **Screen Walls**

All screen walls should be modeled panel by panel such that their top and bottom are spanned between successive levels with its ends joined to the edges of connected columns.

![Screen wall](image)

**Figure 3.2.10  Screen wall**
viii) Door and Window Openings:

The openings can be modeled as two aligned walls with a lintel beam spanned between them. Even though, the dimensions of the structural opening so formed are larger than the architectural requirement, the surrounding concrete fill around the openings will not be included into the model.

![Figure 3.2.10 Structural opening](image)

ix) Other Openings:

To be formed by adding Wall Opening (i.e. System Family: Rectangular Straight Wall Opening) to wall element. For opening of other shapes, new wall base generic families have to be created to suit specific need.

3.2.2 Family Customization: Basic Wall (System Family)

i) All Wall family type should be defined with single structure layer only with required thickness and concrete grade.

![Figure 3.2.11 Edit Assembly dialog for Basic Wall](image)
3.3 Beams

3.3.1 Modelling approach

i) All beams should be modeled with appropriate family type from Structural Framing or Structural Beam System category families.

ii) All continuous beams should be modeled span by span.

iii) All beams should be connected to their supports by one of the following methods:

      Case a – Main beam

      The handle of the beam should be connected to the reference plane of its supporting beams. Normally, it is defined along the center of a Structural Framing family.

      Figure 3.3.1 Secondary beam supported on main beam (plan view)

      Case b - Column

      Beam supported on column should model with its end handle attached to any one of the reference planes of the column. Normally, they are along the major and minor axes of the column section

      Figure 3.3.2 Beams connected to column (plan view).
Case c - Wall

In general, the handle of the beam should connect to the centerline of its wall support except lintel beam which can be joined to the end of the wall. In the latter case, the beam handle can attach to edge of the wall end.

![Figure 3.3.3 Beams connected to their supports.](image)

iv) To model inverted beam including lintel beam, modeler is required to select “Other” under the **z-Direction Justification** in the element's Properties palette and enter the beam up-stand value into **z-Direction Offset Value**.

![Figure 3.3.4 To specify inverted beam in its Properties palette.](image)

To cancel the beam up-stand, modeler should enter “0” into **z-Direction Offset Value**, hence select “Top” from the **z-Direction Justification** drop-down list.

![Figure 3.3.5 To cancel the up-stand of inverted beam](image)

v) To model special element like cantilever and isolated beam (e.g. tie beam and ground beam which does not sustain any slabs), modeler is
advised to specify the structural usage of this element in its Properties palette under **Comments** as below:

“Cantilever”;
“Tie Beam”; and
“Ground Beam”.

The description here can facilitate other model user to sort out the elements according to their structural usage within a model.

![Figure 3.3.6](image.png)  
*Figure 3.3.6 To specify the structural usage a beam*

vi) To improve the appearance at the connections with adjacent slab and wall elements, modeler should make the newly placed slab element joined with these beam elements.

### 3.3.2 Family Customization: Structural Framing (Loadable Family)

i) The reference plane “Centre (Front/Back)” predefined in Revit Structural Framing family template should cut across the beam section and locate at the mid-point of the horizontal overall dimensions.

![Figure 3.3.7](image.png)  
*Figure 3.3.7 Location of Reference plans for Structural Framing family*
ii) The following sharable parameters have to be added to the Family such that they can provide relevant information for other model users or element annotating:

**Beam Width;**

**Beam Depth;**

**Features** – e.g. “Rectangular”, “Cranked”, “Tapered” and “Stepped” etc…;

**Tag 1 ~ 5** – for beam tagging, contents refer to the format adopted in the standards Structural Framing Tags Family adopted.

![Customized parameters for Structural Framing family](image)

Figure 3.3.8 Customized parameters for Structural Framing family

iii) Both sides and bottom of the family should be painted with specific material, name as, “Beam side formwork”, “Beam bottom formwork” and “Beam bottom formwork (inclined)” so that the areas of beam formworks in different location can be extracted.

![Formwork areas for Structural Framing family](image)

Figure 3.3.9 Formwork areas for Structural Framing family
3.4 Ground Beams

3.4.1 Modelling approach

i) Ground beam is to be modeled with appropriate types from Structural Framing or Structural Beam System category family for the beam and In-Place model under Generic Models family category for the binding layer.

ii) The extent of the binding layer has to be defined within the clear span of the beam.

![Plan View](image1.png) ![3D View](image2.png)

*Figure 3.4.1 Modelling of ground beam*

iii) The In-Place model for the binding layer should be provided with a family name which can be recognized as blinding layer for that particular beam.

iv) Description such as “Binding under GB1” is advised to be added to the Comments of its Properties palette.

![Family name for mass fill](image3.png) ![In-Place model Properties palette](image4.png)

*Figure 3.4.2 In-Place model for binding layer*

3.4.2 Family Customization: Structural Framing (Loadable Family)

See Section 3.3.2.
3.5 Suspended Slabs and Transfer Structures (transfer beams and plates)

3.5.1 Modelling approach

i) All these elements should be modeled with appropriate types from Floor category family with its Property Structural Usage set to “Bearing” i.e. in Revit ribbon, select Home tag ➤ Structure panel ➤ Floor dropdown list ➤ Structural Floor.

ii) For those elements not to be included into the building structure analytical model, the element property Structural check box should be unchecked.

iii) All slab elements should be modeled panel by panel.

iv) All slab (except flat slab and free edge) boundaries should be defined either
   a. along the center lines of supporting walls; or
   b. along the reference planes of supporting beams; or
   c. edge of supporting slab.

![Figure 3.5.1 Typical slab element supported on wall and beams](image)

v) For flat slab floor system, the vertex of the slab boundaries should be located at the centers of the supporting columns.

vi) For binding layer below suspended slab, paragraph v) of Section 3.6 refers.

vii) All walls should extend to the top level of the slabs being supported.

viii) For framing plan production purpose, all slabs should be:
a. joined manually with neighboring slabs in order to eliminate the solid lines between them;

b. assigned with correct **Span Direction** for one-way slabs; and

c. annotated with **Floor Tags** instead of symbol.

ix) It is advised to specify the usage, where necessary, of slab elements in its Properties under the **Comments** for facilitating quantities takeoff purpose e.g. “Bay Window”, “A/C Hood”, “Landing” and “Canopy”…etc.

![Figure 3.5.2 Comments properties for Floor element.](image)

x) All semi or fully-precast slabs should be modeled with as suspended slab but assigned with appropriate material specified for that kind of construction, paragraph (xiii) in Section 1 refers.

![Figure 3.5.3 Material properties for pre-cast slab element.](image)

xi) **Channels and Trenches**

Modelling method is greatly relied on the design assumption. The standard methods adopted are listed in the table below. Similar principle should be followed for cases not included in the table.

![Diagram](image)

(a) **Reduced slab thickness** was adopted for design  
(b) The reduced section does not affect the slab design.  
(c) Design is carried out for individual portions of slabs.
(d) Slab of uniform thickness.  
(e) Deep trench where the trench depth is greater than the slab thickness.

Table 3.5.4 Modelling of channel on slab

3.5.2 Family Customization: Structural Floor (System Family)

i) All the Family Types should be composed of structure layer only and assigned with suitable concrete material and slab thickness.

![Edit Assembly dialog for Structural Floor](image)

Figure 3.5.5 Edit Assembly dialog for Structural Floor

The slab thickness should be indicated in the **Description** property so that it can be shown when applying **Span Direction** to slab elements.
3.6 On-Grade Slabs / Floating Slabs / Machine Bases / Pile Caps / Raft Footings

3.6.1 Modelling approach

i) All these elements should be composed of two types of Revit element: the structural component and the binding layer beneath.

ii) The structural component should be modeled using appropriate category families according to paragraph ix) in Section 1 while the binding layer should be modeled with In-Place model under Generic family category.

iii) The boundaries of both the structural component and its binding layer should be defined along the edges of the neighbor elements if any.

iv) Modeler is advised to specify the usage of the element in its Properties palette under Comments as below:

"On-Grade Slab";
"Floating Slabs";
"Machine Base";
"Pile Cap";
"Raft Footing"; and other similar.

The description here can facilitate other model user to sort out the elements according to their structural usage within a model.

v) The In-Place model for the binding layer should be provided with a family name (e.g. “Binding under GS8”) and a similar description in its Comments property (e.g. “Binding under GS8”) that its location and function can be easily identified.

3.6.2 Family Customization: Foundation Slab (System Family)

i) All the Family Types should compose of a structure layer only and should be assigned with suitable concrete material and thickness.
Figure 3.6.1 Edit Assembly dialog for Foundation Slab
3.7 Staircases

3.7.1 Modelling approach

i) All staircases are to be modeled as a composition of landings and stair flights.

![Figure 3.7.1 Modelling of Staircase](image)

ii) Landing slab, including half landing, stair beam and stair flight are to be modeled using Structural Floor, Structural Framing and Stair Families respectively.

iii) The stair flight should be spanned between the edges of the landing elements.

iv) Note that element modeled by Stair family is belonged to architectural discipline model element.

v) In-Place model under Floor category, if required, should be used to supplement the modelling of staircase.

![Figure 3.7.2 In-Place model applied for staircase modelling](image)

vi) The In-place model should be provided with a family name which can
be recognized as mass fill for that particular stair. Preferably, relevant information should also incorporate into its Comments property so that it is can easily be identified e.g. “Mass fill at SS1 stair end”.

![Family name for mass fill In-Place model](image1)

![In-Place model Properties palette](image2)

**Figure 3.7.3 In-Place model for half-landing**

vii) The floor elements should be specified as “Landing” or “Half-Landing” in its Comments property.

![In-place model applied for staircase modelling](image3)

**Figure 3.7.4 In-place model applied for staircase modelling**

3.7.2 *Family Customization: Stair (System Family)*

i) Waist thickness has to be input into the property Description.

![Type Properties dialog for Stair Family](image4)

**Figure 3.7.4 Type Properties dialog for Stair Family.**
3.8 Water Tanks

(a) Top Plan View  (b) Section “1-1”

Figure 3.8.1 Water Tank

3.8.1 Modelling approach

i) In general, water tank have no standard layout but are composed of standard component elements such as side walls, top and bottom slabs and, sometimes, beams as well. It is advised to assemble water tanks as individual sub-models and linked them into a host model.

ii) Plinths are advised to be modeled as In-Place model under Generic category in the host model.

iii) Normally, elements of water tank will not be parts of structural analytical model so relevant setting in their element Properties palettes should be made in order to exclude them from the analytical model.

<table>
<thead>
<tr>
<th>Elements</th>
<th>Properties</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wall</td>
<td>Enable</td>
<td>Uncheck the checker box.</td>
</tr>
<tr>
<td></td>
<td>Analytical Model</td>
<td></td>
</tr>
<tr>
<td>Beam</td>
<td>Analyze As</td>
<td>Select the “Not for analysis” from the drop-down list.</td>
</tr>
<tr>
<td>Slab</td>
<td>Structural</td>
<td>Uncheck the checker box.</td>
</tr>
</tbody>
</table>

iv) All fillets and curbs are to be modeled as In-place models of Generic family category with the same concrete grade as the water tank.

v) Vertical fillets are formed by Solid Extrusion spanned from the bottom of top slab extended to top of bottoms slab.

vi) While horizontal fillets are formed by Solid Sweep with its path defined along the intercept lines between the side walls and top of bottom slab.
vii) Curbs surround water tank opening and edges should be modeled with In-place model under Generic family category.

viii) Section 3.10 should also be referred for modelling of fillets and curbs.
3.9 Precast Façades (non-structural)

3.9.1 Modelling approach

i) All precast façades should be placed into the model in form of family instances instead of assembled in its host model.

ii) Generic family has to be used to create the precast façade families.

3.9.2 Family Customization: Generic (Loadable Family)

i) Note that Generic family can only be an assembly of loadable family elements including Structural Framing, Structural Column and Generic Models only but not system families like Structural Floor and Basic Wall.

ii) As a result, the analytical model formed in the family is not sufficient for exporting to form analytical model.

iii) To exclude the structural elements in façade families from including into the analytical model for the whole building structure, their properties should be set as “not for analytical model”.

iv) To facilitate framing plan production, a Fill Region family with appropriate hatched pattern should be incorporated to the family. The visibility setting of the fill region should be selected to Coarse Detail Level only.

v) Accordingly, all elements in the family should have the visibility settings as follow:

![Sample of Fill Region family for façade family](image1)

![Family Element Visibility Settings dialog for Fill Region](image2)

Figure 3.9.1 Fill region for precast façade.
vi) Two different materials should be assigned to the exposed and embedded portions e.g. the portion embedded into the supporting wall.

![Exposed portion and Embedded Portion](image)

*Figure 3.9.3 Different portions of facade*

vii) Surfaces at the edges of the facade model should be painted with appropriate materials such that the areas of these surfaces can be captured in Revit Material Schedules.

(a) Painted surface along the side of facade wall

(b) Painted surface at the side of facade boot

*Figure 3.9.4 Paints applied to facade*
3.10 Plinths / Mass Fills / Curbs / Fillets

3.10.1 Modelling approach

i) These elements are advised to be modeled with In-Place model under Generic family category and assigned with required concrete grade.

ii) The In-Place model should be provided with a family name such that their locations and functions can be identified for material scheduling.

iii) Description such as “Plinth for 2000L Flush W/T at R/F” is advised to be added to its Comments Property.
4 Notes for Family, In-place Model and Sub-Model

4.1 Comparison between family, in-place Model and sub-model

The following table sums up the characteristics and usages of loadable family, in-place model and sub-model in order to assist modeler to decide between the modelling techniques.

<table>
<thead>
<tr>
<th>Characteristics</th>
<th>Loadable Families</th>
<th>In-Plane Model</th>
<th>Sub-Model</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supplementary parts to existing families especially those belonging to system families</td>
<td>✓</td>
<td>✓</td>
<td>✗</td>
<td>Irregular portion of structural wall / rectangular column and channel on slab</td>
</tr>
<tr>
<td>Re-usable by other projects</td>
<td>✓</td>
<td>✗</td>
<td>✓</td>
<td>Cranked Beams and Precast elements</td>
</tr>
<tr>
<td>Sub-models which involve assembly of elements belonging to system families e.g. wall and floor</td>
<td>✗</td>
<td>✗</td>
<td>✓</td>
<td>Water Tank</td>
</tr>
<tr>
<td>Only the no. count of the element within the hoist model is required.</td>
<td>✓</td>
<td>✗</td>
<td>✗</td>
<td>Precast elements</td>
</tr>
</tbody>
</table>

4.2 Generic Family

i) The quantities of generic elements in the linked sub-model will not be included in the Material Takeoff Schedule of its host model. They have to be extracted from the sub-model itself.

ii) For Revit Structure 2011, volume of the element under Generic category (created by in-place model) will equal to zero in the Material takeoff schedule if Paint has been applied on the element surfaces.
5 Model Auditing

This section provides a check list for project team to check the compliance of the BIM structural models to this guide. Modeler is required to carry out a self audit according to this guide to ensure that the developed models can comply with this guide before issuing the models for project collaboration. On the other hand, project team is advised to return the auditing result to the modelers for rectifying the models when non-compliance and modeling errors are discovered.

Checklist for RC Superstructure BIM Model

<table>
<thead>
<tr>
<th>Items</th>
<th>Descriptions</th>
<th>Yes</th>
<th>No</th>
<th>N/A</th>
<th>Reference / Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A</strong></td>
<td>General Principle</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>A.1</td>
<td>Models developed are based on the project standards and families found in Housing Authority BIM library.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>A.2</td>
<td>Models contain structural elements only</td>
<td></td>
<td></td>
<td></td>
<td>1 i)</td>
</tr>
<tr>
<td>A.3</td>
<td>Model divided into sub-models and complied with the Model hierarchy stated in Project BIM Execution Plan</td>
<td></td>
<td></td>
<td></td>
<td>1 iii) ~ vii)</td>
</tr>
<tr>
<td>A.4</td>
<td>Appropriate families have been used</td>
<td></td>
<td></td>
<td></td>
<td>1 ix)</td>
</tr>
<tr>
<td>A.5</td>
<td>Assigned materials:</td>
<td></td>
<td></td>
<td></td>
<td>1 xiii)</td>
</tr>
<tr>
<td>A.5.1</td>
<td>construction method can be identified;</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>A.5.2</td>
<td>the material properties complied with prevailed code of practice and relevant Bulling Regulations.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>A.6</td>
<td>Every structural element has been assigned with a mark</td>
<td></td>
<td></td>
<td></td>
<td>1 xvii)</td>
</tr>
<tr>
<td><strong>B</strong></td>
<td>Levels of Details</td>
<td></td>
<td></td>
<td></td>
<td>2</td>
</tr>
<tr>
<td>B.1</td>
<td>Fully annotated for drawing production.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.2</td>
<td>Full model for project collaboration.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>B.3</td>
<td>Ready to export to form analytical model.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>C</strong></td>
<td>Modelling of Elements and Components</td>
<td></td>
<td></td>
<td></td>
<td>3</td>
</tr>
<tr>
<td>C.1</td>
<td>Columns / Posts / Hangers</td>
<td></td>
<td></td>
<td></td>
<td>3.1.</td>
</tr>
<tr>
<td>C.1.1</td>
<td>Each element has been defined between appropriate levels.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.1 ii)</td>
</tr>
<tr>
<td>Items</td>
<td>Descriptions</td>
<td>Yes</td>
<td>No</td>
<td>N/A</td>
<td>Reference / Remarks</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----</td>
<td>----</td>
<td>-----</td>
<td>---------------------</td>
</tr>
<tr>
<td>C.1.2</td>
<td>Appropriate comments have been added to <code>Comments</code> property where necessary.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.1 iii)</td>
</tr>
<tr>
<td>C.1.3</td>
<td>Irregular shape columns have been modeled as per design assumption.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.1 iv)</td>
</tr>
<tr>
<td>C.1.4</td>
<td>Have new families been created (i.e. other than that in HA BIM library)? If yes, for every new families:</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>a. All &quot;Center&quot; reference planes are located at the mid-points of the section overall dimensions perpendicular to them.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.2 i)</td>
</tr>
<tr>
<td></td>
<td>b. Sufficient sharable parameters have assigned to new families for quantities takeoff.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.2 ii)</td>
</tr>
<tr>
<td></td>
<td>c. Column sizes have been added to their <code>Description</code> property of the new families.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.2 iv)</td>
</tr>
<tr>
<td></td>
<td>d. All vertical surfaces have been painted with &quot;Column Formwork&quot; materials.</td>
<td></td>
<td></td>
<td></td>
<td>3.1.2 v)</td>
</tr>
<tr>
<td>C.2</td>
<td>Shear / Core / Bearing / Hanger / Stud / Screen Walls and Parapets</td>
<td></td>
<td></td>
<td></td>
<td>3.2</td>
</tr>
<tr>
<td>C.2.1</td>
<td>Each element has been defined between appropriate levels.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 iii)</td>
</tr>
<tr>
<td>C.2.2</td>
<td>All top of wall has been extended to top level of slab being supported.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 iii)</td>
</tr>
<tr>
<td>C.2.3</td>
<td>Appropriate comments have been added to <code>Comments</code> property where necessary.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 iv)</td>
</tr>
<tr>
<td>C.2.4</td>
<td>According the design assumption, mass fills have been added to wall using In-place module under Walls Column category for irregular shape wall.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 v)</td>
</tr>
<tr>
<td>C.2.5</td>
<td>Parapets have been placed at correct level.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 vi)</td>
</tr>
<tr>
<td>C.2.6</td>
<td>Parapet walls have been modeled as individual wall spanned between piers edge</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C.2.7</td>
<td>Piers have been modeled with both <code>Top Level</code> and <code>Base Level</code> assigned with identical level together with the <code>Top Offset</code> equal to the required parapet height.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C.2.8</td>
<td>Appropriate method has been used to model screen walls.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 vii)</td>
</tr>
<tr>
<td>C.2.9</td>
<td>Appropriate method has been used to model opening for different opening size and shapes.</td>
<td></td>
<td></td>
<td></td>
<td>3.2.1 viii)</td>
</tr>
<tr>
<td>C.2.10</td>
<td>Have new family types been created (i.e. other than that in HA project template)?</td>
<td></td>
<td></td>
<td></td>
<td>If no, skip to C.3</td>
</tr>
<tr>
<td>C.2.11</td>
<td>New family types contain single core concrete layer only and assigned with appropriate concrete</td>
<td></td>
<td></td>
<td></td>
<td>3.2.2 i)</td>
</tr>
<tr>
<td>Items</td>
<td>Descriptions</td>
<td>Yes</td>
<td>No</td>
<td>N/A</td>
<td>Reference / Remarks</td>
</tr>
<tr>
<td>-------</td>
<td>--------------</td>
<td>-----</td>
<td>----</td>
<td>-----</td>
<td>---------------------</td>
</tr>
<tr>
<td>grade.</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C.3</td>
<td>Beam</td>
<td></td>
<td></td>
<td></td>
<td>3.3</td>
</tr>
<tr>
<td>C.3.1</td>
<td>Continuous beams have been modeled span by span.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.1 ii)</td>
</tr>
<tr>
<td>C.3.2</td>
<td>All beams have been connected to their supports with proper method.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.1 iii)</td>
</tr>
<tr>
<td>C.3.3</td>
<td>Inverted beams have been model with <strong>z-Direction Justification</strong> set to “Other” and set to “Top” otherwise.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.1 iv)</td>
</tr>
<tr>
<td>C.3.4</td>
<td>“Cantilever” and isolated beams like “Tie beam” &amp; “Ground beam”...etc have been specified in <strong>Comments</strong> property</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.1 v)</td>
</tr>
<tr>
<td>C.3.5</td>
<td>Joined with connected slab and wall elements.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.1 iv)</td>
</tr>
<tr>
<td>C.3.6</td>
<td>Have new family types been created (i.e. other than that in HA project template)?</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>If no, skip to C.4</td>
</tr>
<tr>
<td></td>
<td>a. The “Center (Front/Back)” reference plane is located at the mid-points of the overall horizontal dimensions for the section.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.2 i)</td>
</tr>
<tr>
<td></td>
<td>b. Sufficient sharable parameters have assigned to new families for quantities takeoff.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.2 ii)</td>
</tr>
<tr>
<td></td>
<td>c. All side and bottom surfaces have been painted with “Beam side formwork” and “Beam bottom formwork” materials respectively.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.3.2 iii)</td>
</tr>
<tr>
<td>C.4</td>
<td>Ground Beam</td>
<td></td>
<td></td>
<td></td>
<td>3.4</td>
</tr>
<tr>
<td>C.4.1</td>
<td>Each ground beam Model as a composition of a Structural Framing family type and an In-Place model under Generic Models category element.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.4.1 i)</td>
</tr>
<tr>
<td>C.4.2</td>
<td>The binding layer defined within the clear span of the ground beam only.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.4.1 ii)</td>
</tr>
<tr>
<td>C.4.3</td>
<td>A proper description has been applied to the family name of the binding layer.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.4.1 iii)</td>
</tr>
<tr>
<td>C.4.4</td>
<td>A proper description has been applied to the <strong>Comments</strong> of the property of the binding layer.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.4.1 iv)</td>
</tr>
<tr>
<td>C.5</td>
<td>Suspended Slabs &amp; Transfer Structures</td>
<td></td>
<td></td>
<td></td>
<td>3.5</td>
</tr>
<tr>
<td>C.5.1</td>
<td>All slabs have been modeled panel by panel.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 iii)</td>
</tr>
<tr>
<td>C.5.2</td>
<td>All slabs boundaries have been their defined properly.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 iv) &amp; v)</td>
</tr>
<tr>
<td>C.5.3</td>
<td>Binding layer below suspended slab have been modeled according to paragraph v) of Section 3.6.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5 vi)</td>
</tr>
<tr>
<td>Items</td>
<td>Descriptions</td>
<td>Yes</td>
<td>No</td>
<td>N/A</td>
<td>Reference / Remarks</td>
</tr>
<tr>
<td>---------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----</td>
<td>----</td>
<td>-----</td>
<td>---------------------</td>
</tr>
<tr>
<td>C.5.4</td>
<td>Wall attached to the top level of slabs being supported.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 vii)</td>
</tr>
<tr>
<td>C.5.5</td>
<td>Slabs joined with all neighbor slabs</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 viii)a</td>
</tr>
<tr>
<td>C.5.6</td>
<td>Slabs were annotated with Floor tags instead of symbols.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 viii)b &amp; c</td>
</tr>
<tr>
<td>C.5.7</td>
<td>A proper description has been applied to the Comments property of the floor elements which have specific usage.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 ix)</td>
</tr>
<tr>
<td>C.5.8</td>
<td>Precast or Semi-precast materials have been specified for precast of semi-precast elements.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 x)</td>
</tr>
<tr>
<td>C.5.9</td>
<td>Channels and trenches have been modeled according to design assumption.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.1 xi)</td>
</tr>
<tr>
<td>C.5.10</td>
<td>Have new family types created (i.e. other than that in HA project template)?</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>If no, skip to C.6</td>
</tr>
<tr>
<td>C.5.11</td>
<td>New family types contain single core concrete layer only and assigned with appropriate concrete grade.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.2 i)</td>
</tr>
<tr>
<td>C.5.12</td>
<td>The slab thickness has been indicated in the Type property under Description</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.5.2 ii)</td>
</tr>
<tr>
<td>C.6</td>
<td>On-Grade Slabs / Floating Slabs / Machine Bases / Pile Caps / Raft Footings</td>
<td></td>
<td></td>
<td></td>
<td>3.6</td>
</tr>
<tr>
<td>C.6.1</td>
<td>All elements composed of a structural component and a binding layer element.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.6.1 i)</td>
</tr>
<tr>
<td>C.6.2</td>
<td>All structural components were modeled with appropriate category families while the binding layer were modeled with In-Place model under Generic family category</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.6.1 ii)</td>
</tr>
<tr>
<td>C.6.3</td>
<td>The boundaries of both the structural component and the binding layer were defined along the edge of the neighbor elements if any.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.6.1 iii)</td>
</tr>
<tr>
<td>C.6.4</td>
<td>Usages have been specified in the structural component elements’ Comments property.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.6.1 iv)</td>
</tr>
<tr>
<td>C.6.5</td>
<td>The In-Place model for the binding layer was provided with identifiable family name and a similar description in its Comments property.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.6.1 v)</td>
</tr>
<tr>
<td>C.6.6</td>
<td>Has new Foundation Slab family type created (i.e. other than that in HA project template)?</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>If no, skip to C.7</td>
</tr>
<tr>
<td>C.6.7</td>
<td>All new Family Types were composed of single core layer only and were assigned with suitable concrete material and thickness.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.6.2 i)</td>
</tr>
<tr>
<td>C.7</td>
<td>Staircase</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.7</td>
</tr>
<tr>
<td>C.7.1</td>
<td>All staircases were composed of landing elements</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.7.1 i)</td>
</tr>
<tr>
<td>Items</td>
<td>Descriptions</td>
<td>Yes</td>
<td>No</td>
<td>N/A</td>
<td>Reference / Remarks</td>
</tr>
<tr>
<td>-------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----</td>
<td>----</td>
<td>-----</td>
<td>--------------------</td>
</tr>
<tr>
<td></td>
<td>and stair flight elements.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C.7.2</td>
<td>Half landings and stair beams were modeled with Structural Floor and Structural Framing Families respectively.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.1 ii)</td>
</tr>
<tr>
<td>C.7.3</td>
<td>Stair flights were modeled with Stair Family.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.1 ii)</td>
</tr>
<tr>
<td>C.7.4</td>
<td>The stair flights were spanned between the edges of the landing elements.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.1 iii)</td>
</tr>
<tr>
<td>C.7.5</td>
<td>In-Place model under Floor category were used to supplement the modelling of staircase.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.1 v)</td>
</tr>
<tr>
<td>C.7.6</td>
<td>The in-place model layer was provided with a identifiable family name and a description in its Comments property.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.1 vi)</td>
</tr>
<tr>
<td>C.7.7</td>
<td>The floor elements should be specified as “Landing” or “Half-Landing” in its Comments property.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.1 vii)</td>
</tr>
<tr>
<td>C.7.8</td>
<td>Have new Stair family types created (i.e. other than that in HA project template)?</td>
<td></td>
<td></td>
<td></td>
<td>If no, skip to C.8</td>
</tr>
<tr>
<td>C.7.9</td>
<td>Waist thicknesses were input into the type property Description.</td>
<td></td>
<td></td>
<td></td>
<td>3.7.2 i)</td>
</tr>
<tr>
<td>C.8</td>
<td>Water Tank</td>
<td></td>
<td></td>
<td></td>
<td>3.8</td>
</tr>
<tr>
<td>C.8.1</td>
<td>All water tanks were modeled as individual sub-models linked into the hoist model.</td>
<td></td>
<td></td>
<td></td>
<td>3.8.1 i)</td>
</tr>
<tr>
<td>C.8.2</td>
<td>Plinths were modeled in the host model.</td>
<td></td>
<td></td>
<td></td>
<td>3.8.1 ii)</td>
</tr>
<tr>
<td>C.8.3</td>
<td>Vertical fillets were spanned from the bottom of top slab extended to top of bottoms slab.</td>
<td></td>
<td></td>
<td></td>
<td>3.8.2 v)</td>
</tr>
<tr>
<td>C.8.4</td>
<td>Horizontal fillets were spanned along the intercept lines between the side walls and top of bottom slab.</td>
<td></td>
<td></td>
<td></td>
<td>3.8.2 vi)</td>
</tr>
<tr>
<td>C.8.5</td>
<td>Curbs surround water tank opening and edges were modeled with In-place model under Generic family category.</td>
<td></td>
<td></td>
<td></td>
<td>3.8.2 vii)</td>
</tr>
<tr>
<td>C.9</td>
<td>Precast Façade</td>
<td></td>
<td></td>
<td></td>
<td>3.9</td>
</tr>
<tr>
<td>C.9.1</td>
<td>All precast façades were placed into the model in form of family instances.</td>
<td></td>
<td></td>
<td></td>
<td>3.9.1 i)</td>
</tr>
<tr>
<td>C.9.2</td>
<td>Have new families created (i.e. other than that in HA project template)?</td>
<td></td>
<td></td>
<td></td>
<td>If no, skip to C.10</td>
</tr>
<tr>
<td>C.9.3</td>
<td>All components were excluded from analytical model.</td>
<td></td>
<td></td>
<td></td>
<td>3.9.1 ii)</td>
</tr>
<tr>
<td>C.9.4</td>
<td>Only hatched patterns would be shown in plan view at the locations of the precast façade when the visibility of the plan view was changed to</td>
<td></td>
<td></td>
<td></td>
<td>3.9.1 iv)</td>
</tr>
<tr>
<td>Items</td>
<td>Descriptions</td>
<td>Yes</td>
<td>No</td>
<td>N/A</td>
<td>Reference / Remarks</td>
</tr>
<tr>
<td>-------</td>
<td>--------------</td>
<td>-----</td>
<td>----</td>
<td>-----</td>
<td>---------------------</td>
</tr>
<tr>
<td></td>
<td>Coarse Detail Level only.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C.9.5</td>
<td>All elements in the family should have proper visibility settings</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.9.1 v)</td>
</tr>
<tr>
<td>C.9.6</td>
<td>Two different materials were assigned to the exposed and embedded portions</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.9.1 vi)</td>
</tr>
<tr>
<td>C.9.7</td>
<td>Surfaces at the edges of the facade model were painted with materials such that the areas of those surfaces can be captured in Revit Material Schedules.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.9.1 vii)</td>
</tr>
<tr>
<td>C.10</td>
<td>Plinth / Mass Fill / Curb / Fillets</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>C.10.1</td>
<td>These elements were modeled with In-Place model under Generic family category and assigned with required concrete grade.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.10.1 i)</td>
</tr>
<tr>
<td>C.10.2</td>
<td>The In-Place models were provided with a family name such that their locations and functions can be identified for material scheduling.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.10.1 ii)</td>
</tr>
<tr>
<td>C.10.3</td>
<td>Description such as “Plinth for 2000L Flush W/T at R/F” is advised to be added to its Comments property.</td>
<td>☐</td>
<td>☐</td>
<td>☐</td>
<td>3.10.1 iii)</td>
</tr>
</tbody>
</table>
ANNEXES

ANNEX I – Standard Template ................................................................. 42
ANNEX II – Architectural Drawing ......................................................... 45
ANNEX III – Structural Wall ................................................................. 51
ANNEX IV – Irregular – Shaped Structural Wall ................................. 64
ANNEX V – Beam ............................................................................. 68
ANNEX VI – Ground Beam ................................................................. 84
ANNEX VII – Floor Slab ................................................................. 88
ANNEX VIII – Inclined Slab ................................................................. 120
ANNEX IX - Slab with Top Fall ............................................................ 123
ANNEX X – Slabs Joint ................................................................. 127
ANNEX XI – Precast Stair Flight ......................................................... 134
ANNEX XII – Precast Facades ............................................................ 156
ANNEX XIII – Annotations ................................................................. 164
ANNEX XIV - Excel ........................................................................ 180
ANNEX I – Standard Template

Objective

To start a new Revit model with Housing Department standard project template.

Prerequisite

Obtain the latest version of model template file.

Open a New Model

Steps:
1. Start Revit Structure. The Recent Files window displays.

2. Click ➤ New ➤ Project.

Figure A1.1

- 42 -
3. In the New Project dialog, for Template file, click Browse.

4. Navigate to the location of the desired project template, select the template file (with the file extension “.rte”), and click Open.

5. For Create new, click Project.

6. Click OK.

7. The Revit User Interface displays.
8. To save the file. Click 

9. To close the file. Click 

---

Figure A1.4
ANNEX II – Architectural Drawing

Objective

To prepare and link an architectural CAD file (general building plan) to a Revit project file as modeling reference.

Relocate the Origin in CAD Drawing

Notes:
1. Revit can only maintain elements placed within 20 miles from the project origin. Revit Structure User’s Guide refers.
2. According to HA practice, all CAD drawings are drawn to the Global Coordinate System. It is advised to redefine the CAD drawing to center of the building.
3. All irrelevant objects located beyond the floor plan should be removed.

Steps:
1. Open the AutoCAD architectural floor plan.
2. Determine the preferred location for the origin of new UCS. (Recommendation: interception point of building center lines.)
3. Type UCS, and then press Enter on keyboard.
4. Specify the origin of user coordinate system by select a point on the drawing.
5. Press Enter to accept.
   (Tip: To view the location of the new UCS icon: Select View in the toolbar ➤ Display ➤ UCS Icon ➤ made Origin checked.

6. At the Command prompt, enter “wblock”.
7. In the Write Block dialog box, click Select Objects button.

8. Use mouse to select the extent of site to be included in the new drawing. Press ENTER to complete object selection.

9. Under Destination, enter a file name and path for the new drawing, or click the [...] button to display a standard file selection dialog box.

10. Click OK. A new drawing is created with the selected objects and newly defined coordinate system.
Open Existing Project Files

Steps:

Open a Revit file in which the required levels have been defined for the project.

Add New Floor Plan View

Notes:
User can check whether the required plan view exists in the Project Browser. If yes, skip this topic.
Steps:
1. Click View tab ➤ Create panel ➤ Plan Views drop-down ➤ (Floor Plan).
2. In the New Plan dialog, select, say, 7/F or other level(s) for which you want to create a plan view.
3. If you want to create a plan view for a level that has already an existing plan view, clear the check box for “Do not duplicate existing views”.
4. For Scale, select 1:100 or other as appropriate for the new view.
5. Click OK to finish
Link the CAD File into Revit Model

Notes:
Linking is similar to having an “Xref” in AutoCAD. When the original linked file changes, these changes are reflected in the file when you reload the Revit file.

Steps:

1. Click Insert tab ➤ Link panel ➤ (Link CAD).
2. In the Link CAD Formats dialog, browse to the folder that contains the file to link.
3. Select the file.
4. Specify the link options as below.
5. Click Open.

Figure A2.6
Halftone the Linked CAD File

Steps:
1. Click View tab ➤ Graphics panel ➤ [Visibility/Graphics].
2. In the Visibility/Graphic Overrides dialog, click the Imported Categories tab.
3. In the Halftone column, select the check box for the linked CAD drawing.
4. Click OK.
5. Save and close the file.
ANNEX III – Structural Wall

Objective

Placing, modifying and checking of structural walls in a BIM structural model.

Prerequisite

1. Revit project with levels have been set.
2. Architectural AutoCAD GBP linked to required level.
3. Grid lines have already been drawn according to the GBP.
4. Open the floor plan view for top of the walls concerned.

Create New Wall Types

Purpose:
To create wall type of required properties including thickness and concrete to if the required one is not existed in the template.

Note:
1. Wall is a system family that means family file can not be created for wall but we can define new wall types for individual models.
2. Some commonly used wall types have already defined in the Department standard model template.

Steps:
1. Click Home tab ➤ Structure panel ➤ Wall drop-down ➤ Structural Wall.
2. On the Properties palette, select one of any exist family type, say “Insitu Conc. C35 225 Thk.” (i.e. 225 mm thick wall with in-situ grade C35 concrete), from the Type Selector drop-down.

3. On the Properties palette, click (Edit Type).
4. In the Type Properties dialog, click Duplicate.
5. In the Name dialog, enter a name, say “Insitu Conc. C40 225 Thk.”, for the new type and click OK.

6. Click Edit for Structure in the Type Properties dialog.
7. Change the Material of Structure to “Concrete – C40”, and Thickness to required value in the Edit Assembly dialog. Click OK.

8. In the Type Properties dialog, click OK.

9. Repeat steps 2 to 8 until all required wall types are created.

Place Structural Walls

Purpose:
To add structural walls as per GBP wall locations.

Note:
In order to let the user easier to see the completed walls in plan view, it is advised to change the Visual Style to Consistent Color in the View Control Bar.

Although the following warnings may be prompted up constantly during the process, user can neglect them.
Steps:

1. Roll the mouse wheel to zoom the location of the walls to be placed.
2. Select Home ➤ Structure panel ➤ Wall drop-down ➤ Structural Wall.

3. Select Modify ➤ Place Structural Wall ➤ Draw panel ➤ Line or any Draw tools

4. Select Depth and the base level of the wall from the Options Bar as shown below.

5. On the Option Bar select “Core Face: Exterior” or “Core Face: Interior” for Location line as appropriate.

6. On the Options Bar, select Chain to create a series of walls. Set Offset to 0.0 and leave Radius unselected as appropriate.

7. Select point along the wall as indicated in Figure 12. Use Spacebar to change the orientation of the wall if necessary.

8. Select Modify ➤ Place Structural Wall ➤ Select panel ➤ Modify to finish the placing of walls.

9. Modify wall thickness as required during the course according
10. Repeat the process until all walls are completed.
11. To check the walls have been placed at the desired floor level, select the walls. The top and bottom are shown in the Properties palette.

Modify Structural Walls Properties

Purpose:
To change the properties of existing walls element including thickness & concrete mix.

Steps:
1. Select the structural wall required to change its properties.

2. In the Type Selector drop-down, select the other family type as required.
3. If the required family type does not appear in the list, follow the
steps in the previous sub-topic *Create New Walls Types* to create new wall type.

**Modify Length, Location and Orientation of Structural Walls**

**Purpose:**
To modify the layout of the existing wall element including length, location and orientation.

**Steps:**
1. Select the wall required to modify.

2. To flip the wall:
   Press Spacebar or right click the double arrow beside the wall.

3. To move the wall:
   Right click and drag it to new location.

4. To change the length and orientation of the wall:
   Right click and drag one of the handle (blue dot) at wall ends.

5. Use the modifying tools in Modify panel to make any other change.

6. On the ribbon, click Select panel ➤ Modify to finish.

**Creating Filter for Walls Thickness Checking**

**Purpose:**
To generate filtering criteria for wall thickness checking on framing plan.

Steps:
1. Click View tab ➤ Graphics panel ➤ (Filter).
2. In the Filters dialog, if the required wall filter has already existed, the procedure completed. Click OK to exit. Otherwise continue the following steps.
3. In the Filters dialog, click New.
4. Enter a filter name, say “550 Wall”. Click OK

5. Under Categories, click Walls.

6. From the Filter By list under Filter Rule, select Width.
7. Select the filter operator “equals”.
8. Enter value, say, 550 for the filter
9. Click OK twice.
10. Repeat the above steps to create more filter of all required wall thickness.

Checking Walls Thickness by Applying Filters

Purpose:
To check walls thickness by means of filter function.

Note:
1. Filter is view specific.
2. For facilitating user to view clearly, it is advised to hide the imported CAD file:
   Type VG (shortcut key for Visibility/Graphic) to open the Visibility/ Graphics dialog. Select Imported Categories tag. Unchecked the linked CAD file to make it invisible. Click OK.

Steps:
1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics),
and click the Filters tab.

2. On the Filters tab of the Visibility/Graphic Overrides dialog, click Add. If the required filters are already present, click OK to skip the following steps.

3. Select a filter, say “200 Wall” from the Add Filter dialog, and click OK.

4. Click Override under Projection/Surface Patterns field of the added filter.

5. Change Color and Pattern in the Fill Pattern Graphics dialog as appropriate. Click OK.

6. Repeat Steps 3 to 5 until all Wall filters have been added.

7. Check the Transparent of all unused filters e.g. those for slab. Click OK to finish.
Figure A3.22 Plan view with wall filters applied.

Good Practices:

1. Users are advised also check their work in 3D view & different elevation views in order to ensure the walls have been placed in the collect levels.

2. User can save their View Template for future use. Select View tab ➤ Graphics panel ➤ View Template drop-down ➤ Create template from Current View.

3. On the New View Template dialog, enter, say, “Filter” for Name. Click OK twice to finish.
Disabling Applied Filters for Walls Thickness Checking

Purpose:
To disable the applied walls filters.

Steps:
1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics), and click the Filters tab.
2. Check Transparent for individual the wall filters. Click OK.

Figure A3.23

Adding Walls Marks

Purpose:
To add walls marks to individual wall or group of walls.

Notes:
1. HD standard Wall Tags family is to be used.

Steps:
1. Click Annotate tab ➤ Tag panel ➤ (Tag All).
2. In the Tag All Not Tagged dialog, select HD standard wall tag family. Alternatively click Load to load the family. Click OK to complete.
3. Double click the question marks beside each wall. Type an identity to add marks to individual walls. (Note: it is equivalent to fill up the Mark property of the wall, step 4 refers). Enter to finish.

4. Alternatively, select the wall. In the Properties palette, input the wall mark for Mark.

5. Repeat step 3 or 4 for all walls.

6. In case wall group name is required (e.g. WC17 for WC17a, WC17b & WC17c). Select the walls. On the Properties palette, input the wall group name for Comment.

7. To hide the wall mark, type VG to open the Visibility/Graphics dialog. Select Annotation Categories tag. Unchecked Wall Tags. Click OK to finish.

8. To show the wall mark again, type VG to open the Visibility/Graphics dialog. Select Annotation Categories tag. Checked Wall Tags. Click OK to finish.

9. Save and close the file.
Good Practices:

1. Assigning wall marks by input Mark in Properties palette (i.e. step 3 or 4) instead of using text box is advised. Revit will prompt users when duplicate wall marks are accidentally used.

2. Wall Marks will be used during scheduling.
ANNEX IV – Irregular – Shaped Structural Wall

Objective

To model an irregular-shaped structural wall in which the irregular part will be neglected from structural analysis.

Prerequisite

The basic wall element, without the irregular part, using HD standard family has been placed in the model.

Create In-place Model

1. Locate the concerned wall element.
2. In the ribbon, click Home tag ➤ Model panel ➤
Component drop-down ➤ Model In-place.

3. In the Family Category and Parameters dialog, select Walls for Family Category. Click OK

4. In the Name dialog, type a name for in-place mode, preferably same as the basic wall. Click OK

5. Use reference lines and dimensions to help the sketching of the shape of the irregular part of the wall. On the ribbon, click Home tag ➤ Datum panel ➤ Reference Line.

6. Choose the suite tool under Modify|Place Reference Lines tag ➤ Draw panel to sketch the reference line.

7. To define the outline of the irregular part of the wall, click Home tag ➤ Forms panel ➤ Extrusion.

8. Ensure the Work Plane (i.e. the bottom level of the wall) shown in the Properties palette is at the one decided. Otherwise reset it using the tool in Modify|Create Extrusion tag ➤ Work Plane panel ➤ Set.

9. Create an extrusion for the wall, click Home tag ➤ Forms
10. Choose appropriate draw tool to sketch the profile for the irregular part of the wall from Modify/Create Extrusion tag ➤ Work Plane panel.

11. In the Properties palette, select the required concrete grade for Material.

12. Click Modify/Create Extrusion tag ➤ Mode panel ➤ ✔ Finish Edit Mode to finish.

13. Change to any elevation view in which the top edge of extrusion can be selected later.

14. To align the top edge of the extrusion to the upper floor level, click Modify/Walls tag ➤ Modify panel ➤ Align.

15. Click the level line of the floor level above the reference plane level, and then select the top edge of the extrusion.

16. To create a constraint between the top edge and the aligned floor level, click the lock shown above the floor level line.
17. On the ribbon, click Modify to finish.

Join the Extrusion with the Basic Wall

1. To remove the solid lines between the basic wall and the in-place model, click Modify tag ➤ Geometry panel ➤ Join dropdown list ➤ Join Geometry.

2. Select the basic wall then the in-place model.

3. On the ribbon, click Modify to finish.

Good Practices

Since the irregular part is an in-place under Wall category, its information will be indicate in Revit Quantity and Material Takeoff schedule for Walls.
ANNEX V – Beam

Objective

To add beams into a BIM model.

Prerequisite

1. HD families have loaded into the model.
2. Open the floor plan view for top of the walls concerned.

Good Practices

1. Tie beams is advised to be modeled in assembled domestic block model instead of typical floor sub-model.
2. User may toggle on/off the visibility of the linked CAD GBP file by selecting the corresponding floor plan view, then clicks anywhere within the drawing area and type VG. Select Imported Categories tag. Unchecked/check the GBP CAD file to make it invisible/visible. Click OK.

3. Switch between the Visual Style to Wireframe and Consistent Colors in the View Control Bar to see the structural walls and beams in solid color respectively.
Loading Beam Tag Family (for beam marking)

Purpose:
To load the HA customized beam tag family into the project.

Note:
The HA customized beam tag family should have already been loaded into the HA standard template.

Steps:
1. Click Annotate tab ➤ Tag panel drop-down ➤ Loaded Tags.

2. Check the Loaded Tags for the Structural Framing. If the HA customized beam tag family has already been there. Click OK to finish or process to the steps below otherwise.

3. In Tags dialog, click Load.
4. Navigate to select the required Structural Framing Tag family.
5. In Tags dialog, click the drop-list bottom beside the loaded family and select the required family type e.g. Mark+DxB (figure 3).
6. Click OK to finish.

Creating New Beam Types

Purpose:
To create beam types of required dimension in case they are not existed in the project template.

Note:
1. Most of the common use beam types are already created in the project template.
2. The steps are for the creation of 390(D) x 400(W) beam.

Steps:
1. Click Home tab ➤ Structure panel ➤ Beam.

2. On the Properties palette, select one of any existing rectangular concrete beam family type, say “B345x250” (i.e. 345 depth x 250 width beam) in HD family. See figure 5.
3. On the Properties palette, click (Edit Type).
4. In the Type Properties dialog, click Duplicate.
5. In the Name dialog, enter a name, say “B390x400”, for the new type and click OK.

6. In the Type Properties dialog, enter 400 for b and 390 for h. Click OK.

7. Click Home tab ➤ Select panel ➤ Modify to finish.

Placing Beams (Other than that for Precast Staircases)

Purpose:
To place beams into a model.

Steps:
1. Roll the mouse wheel to zoom the area where the beam to be placed.
2. Click Home tab ➤ Structure panel ➤ Beam.
3. Turn the beam tag option on: Modify|Place Beam ➤ Tag panel ➤ Tag on Placement. (Good Practices)
4. On the Properties palette, select a B950x250 from the Type Selector drop-down in the HD family otherwise create the beam type (see “Creating New Beam Types” above).
5. Select Modify|Place Beam ➤ Draw panel ➤ Line.
6. On the Modify|Place Beam Option bar, check whether the Placement Plane is at the correct level, say UPPER FL.
7. Modify the beam parameters on the Properties palette:
   a. For inverted beam (for down-stand beam see note below), set
      i. \textit{z-Direction Justification} to “Other”;
      ii. \textit{z-Direction Offset Value} to, say, 750.
   b. Select, say Side 2 in this case, in Lateral Justification;
   c. Select, say In-situ Concrete C35, for Beam Material.
   d. Select, say Fixed, for Start and End Release. (Note: Depending on the assumption in analytical model)
   e. Select Auto-detect for Vertical and Horizontal Projection.
   f. Select Yes for Rigid Link.
8. Sketch the beam by clicking the start point and endpoint in the drawing area as shown in Figure A5.10(a)∼(c).
9. To align the left side of the beam to left side of the wall on top of it, click Modify | Place Beam tab ➤ Modify panel ➤ (Align).

10. On the Options Bar:
   g. Uncheck Multiple Alignment.
   h. For the Prefer option select Wall Faces.

11. Click to select the left face of the upper wall and then the left side of the beam. Enter Esc key to finish.
12. Change the beam tag for inverted beam according to “Modifying Beam Tag for Inverted Beams” below.

13. Add sectional for checking the beam vertical alignment, see “Adding Section” below.

14. Repeat the process until all beams are placed.

Good Practices:
1. For down-stand rectangular beam, set z-Direction Justification to Top;
2. In case of change of design from inverted beam to down-stand beam, modeler should set the z-Direction Offset Value to 0 before reset the z-Direction Justification to “Top” otherwise this will cause misleading in element sorting process.
3. Place beam by “draw line” since it can also define the setting-out of the beam such that the setting-out of the beam will be maintained as the width of the beam changed.
4. As a convention, draw beam from bottom to top or from left to right. By adopting this convention, the right or the bottom side of beams will be the Side 1 while the other side will be the Side 2 of the beams.
5. To ensure the beam is connected to the decided structural wall, sketch beam line by connecting its ends to well-defined points e.g. wall center line and then aligning it according to its setting-out.
Placing Supporting Beam for Precast-Staircases at Landing Level

Purpose:
To place supporting beams for precast staircase at landing.

Steps:
1. Load the L-beam: select Insert tab ➤ Load from Library panel ➤ Load Family.
2. On the Load family dialog, navigate to the directory of the family files. Select and Open the files.
3. Make the linked GBP visibility on for locating the supporting. Zoom to the staircase by rolling the mouse wheel.
4. To make the tack tiles in the CAD invisible, if any, click anywhere on the drawing area and type VG. On the Visibility/Graphics dialog, select the Imported Categories.
5. Expand the CAD drawing. Unchecked the corresponding layer, say “08-tacktile1”. See Figure A.14.
6. Draw model line for locating L-beam. Click Home tab ➤ Model panel ➤ Model lines.

7. Select Modify|Place Lines tab ➤ Draw panel ➤ pick line.

8. On the Modify|Place Lines option bar, enter 437.5 for offset.

9. Pick the first step line on the GBP with a green dotted line shown on its right side. Esc to finish. A model line created.

10. Click Home tab ➤ Structure panel ➤ Beam.

11. On the Properties palette, select a L-beam type, say B390x400, in the Type Selector drop-down in the HD L-Beam family otherwise create the beam type. See “Creating New Beam Types” above.

12. Select Modify|Place Beam Wall ➤ Draw panel ➤ Pick Lines.

13. On the Modify|Place Beam Option bar, check whether the
Placement Plane is at the correct level, say, “UPPER FL”.

14. Modify the beam parameters on the Properties palette:
   i. z-Direction Justification to “Other”;
   j. z-Direction Offset Value to, say, -40.
   k. Select “Center”, in Lateral Justification;
   l. Select, say Insitu Concrete C35, for Beam Material.
   m. Set dimension, say, Wing Width to 275 and Web Clear Depth to 210.
   n. Select, say “Pin”, for Start and End Release. (Note: Depending on the assumption in analytical model)
   o. Select “Auto-detect” for Vertical and Horizontal Projection.
   p. Select “Yes” for Rigid Link.

15. Pick the model line created in step 9. A beam is then placed with its center line align with the model line. (Note: neglect any error message)

16. Flip the beam by clicking the double arrow beside the beam as required. See Figure 18

17. Align the beam edge to the model line: select the beam, click Modify | Structural Framing ➤ Modify panel ➤ Move. Select points in the sequence shown in Figure A5.19. Select Modify to finish
18. Delete the model line.
19. Extend the beam to the opposite wall. Select Modify ➤ Modify panel ➤ Trim/Extend Single Element.
20. Select the center line of the opposite wall then the beam. Esc to finish.

![Figure A5.20](a) ![Figure A5.20](b)

21. Repeat the L-beam at the opposite side of the staircase.

**Placing Supporting Beam for Precast Staircases at Half-Landing Level**

**Purpose:**
To place supporting beams for precast staircase at half-landing.

**Steps:**
1. Load the inverted T-beams family: select Insert tab ➤ Load from Library panel ➤ Load Family.
2. On the Load family dialog, navigate to the location of the family files. Select and Open the files.
3. Draw model line for locating a T-beam. Click Home tab ➤ Model panel ➤ Model lines.
4. Select Modify|Place Lines tab ➤ Draw panel ➤ pick line.
5. On the Modify|Place Lines option bar, enter 600 for offset. (Center line of the half-landing)
6. Pick the first step line on the GBP with a green dotted line shown on half-landing.
7. Click Home tab ➤ Structure panel ➤ Beam.

8. On the Properties palette, select a T-beam type, say B390x275, in the Type Selector drop-down in the HD Inverted T-Beam family otherwise create the beam type (see “Creating New Beam Types” above).

9. Select Modify | Place Beam Wall ➤ Draw panel ➤ Pick Lines.

10. On the Modify | Place Beam Option bar, check whether the Placement Plane is at the correct level “UPPER FL”.

11. Modify the beam parameters on the Properties palette:
   i.  *z-Direction Justification* to “Other”;
   ii.  *z-Direction Offset Value* to, say, -40.
   iii. Select “Center”, in *Lateral Justification*;
   iv. Select, say, “Insitu Concrete C35” for *Beam Material*.
   vi. Select, say “Pin”, for *Start and End Release*.
   vii. Select “Auto-detect” for *Vertical and Horizontal Projection*.
   viii. Select “Yes” for *Rigid Link*.

12. Pick the model line created in step 6. A beam is then placed with its center line align with the model line. (Note: neglect any error message)

13. Extend the beam to its support.

14. Adjust the beam level: Select the beam. On the Properties palette, enter -1350 for *Start Level Offset* and *End Level Offset*. Press Esc to finish.

15. Delete the model line.

16. Repeat the above steps for the other half-landing.
Adding Beam Marks

Purpose:
To add beam marks to beam.

Notes:
HD standard Beam Tags family is to be used. See *Loading Beam Tag Family* above.

Steps:
1. Click Annotate tab ➤ Tag panel ➤ Tag by Category.
2. Select the beam. In the Properties palette, input the beam mark for Mark.
3. To hide the beam tag, type VG to open the Visibility/ Graphics dialog. Select Annotation Categories tag. Unchecked Structural Framing Tags.
4. To show the beam tag again, type VG to open the Visibility/ Graphics dialog. Select Annotation Categories tag. Checked Structural Framing Tags.

Good Practices:
1. Assigning wall marks by input Mark in Properties palette instead of using text box is advised. Revit will prompt users when duplicate beam marks are accidentally used.
2. Beam Marks will be used during scheduling.

Modifying Beam Tag for Inverted Beams

Purpose:
To change the beams tag type for inverted rectangular beams.

Steps:
1. Click the beam tag of the inverted beam.
2. On Properties palette, click Edit type.
3. In the Type Properties dialog, select Type, say, “Mark+Size+INV.+ Offset”. Click OK.

Adding Sectional View

Purpose:
To add section view at the desired locations.

Steps:
1. Click View tab ➤ Create panel ➤ Section.
2. In the Type Selector, select Building Section.
3. On the Options Bar, select the view scale.
4. Place the cursor at the starting point of the section, and drag through the model or family.
5. Click when you reach the end point of the section.
6. The section line and the crop region appear and are selected, as the following image shows.

![Figure A5.27]

7. If desired, resize the crop region by dragging the blue controls. The depth of the section view changes accordingly.
8. Click Modify or press Esc to exit the Section tool.
9. To open the section view, double-click the section header, or select the section view from the Sections grouping of the Project Browser.
10. The section view changes when the design changes or the section line is moved.

Modifying Beam Properties

Purpose:
To change the properties of existing beams e.g. size & concrete mix.

Steps:
1. Select the beam/beams.
2. To change beam size: In the Type Selector, select the new beam type.
3. To change other properties: change the information on the
Properties palette.

4. Press Esc to finish.
ANNEX VI – Ground Beam

Objective

To model ground beam with binding layer which does not affect the structural analysis model and also facilitates the process of material take-off.

Prerequisite

Ground beams, without the binding layer, using the HD standard family, has been placed in the model.

Creating In-place Model

1. Locate the floor element concerned.
2. In the ribbon, click Home tag ➤ Model panel ➤ Component drop-down ➤ Model In-place.
3. In the Family Category and Parameters dialog, select Structural Framing for Family Category. Click OK.
4. In the Name dialog, type a name for the in-place mode. Preferably, it can be easily identified for material scheduling. Click OK.

5. On the ribbon, select Home tag ➤ Forms panel ➤ Extrusion.

6. Select any tool on the Click Modify | Create Extrusion ➤ Draw panel to defined the extent of the binding layer on plan view.

7. Click all the lock icon on each of the boundaries to create alignment constraints to the beam outline.

8. Click Modify | Create Extrusion tag ➤ Mode panel ➤ Finish Model.

9. Change the Material to required concrete grade in the Properties palette.

10. Click Modify | Extrusion tag ➤ In-Place Editor panel ➤ Finish Model.

11. Change to any view (except 3D view) that can display the elevation of the beam.

12. Select the binding has just been placed.

13. Click the Modify | Structural Framing tag ➤ Model panel ➤ Edit In-Place. Select again the binding.
14. Select Modify \( \rightarrow \) Extrusion tag \( \rightarrow \) Modify panel \( \rightarrow \) Align.
15. Pick the beam bottom line and then the binding top line.
16. Click the lock to create a constraint for the binding top level to the beam bottom.

17. On the ribbon, click Modify.
18. Select again the binding. Drag the original binding bottom line to a location below the beam bottom level.
19. Type “di” on the keyboard. Create a dimension for the binding thickness. Press Esc twice.

20. Select again the binding. On the Properties palette, specify the Extrusion Start to a value such that the binding layer is equal to required thickness.

21. Select the dimension and click the lock icon to create a constraint to the binding thickness.
22. Click Modify | Extrusion tag ➤ In-Place Editor ➤ ✔ Finish Model to finish.

Good Practices

Since the binding layer is an in-place under Structural Framing category, its information will be indicated in Revit Quantity and Material Takeoff schedule for Structural Framing.
ANNEX VII – Floor Slab

Objective

To place floors slabs into a BIM structural model.

Prerequisite

The BIM model has been created with HD model template otherwise transfer the customized slab family type from the HD model template.

Loading Span Direction Symbol

Purpose:
To load the HA customized span direction symbol family into the project.

Note:
The HA customized span direction symbol family should be already loaded into the HA standard template.

Steps:

1. Click Insert tab ➤ Load from Library panel ➤ Loaded Family.
2. On the Load Family dialog, navigate to the directory of the family file. Select the family file and click Open to complete the process. The updated HA standard family list refers
Creating New Slab Types

Purpose:
To create new slab types with required properties including thickness and concrete grade if they are not existed.

Note:
1. Floor slab is a system family that means no family file can be created.
2. Most of the required slab type have already made in the HD standard project template.

Steps:
1. On the project browser, locate one of the HD customized floor family type. Say Family\Floors\Floor\S160C35.

2. Double click the family type.
3. On the Type Properties dialog, click Duplicate.
4. Enter a name, say S145C35, for the new slab type. Click OK.
5. On the Type Properties dialog, click Edit for Structure.
6. On the Edit Assembly dialog, enter Thickness, say 145, for Structure.
7. Click <By Category> for Material of Structure and then clicking the small button appeared to select concrete grade.

Figure A7.1
8. On the Materials dialog, select the appropriate concrete grade, say Insitu Concrete C35. Click OK twice to complete.

9. On the Type Properties dialog, enter, say 145 for Description. See Figure 3.

10. Click Apply.

11. Repeat steps 3 to 10 until all slab types are created. Click OK to finish.

Placing Floor Slabs at Bedrooms, Corridors and Lift Lobby

Purpose:
To place slabs to the required locations.

Note:
1. To switch on the visibility of the linked GBP: type VG. On the Visibility dialog, click Imported Categories tab. Check the
check box beside the GBP file name. Click OK.

2. For facilitating to view the placed floor slabs, it is advised to change the Visual Style to Consistent Colors in the View Control Bar.

Steps:
1. Roll the mouse wheel to zoom the area concerned. The slab is assumed to be 160 mm thick.

2. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Structural Floor.

3. In the Type Selector choose a structural floor type, say S160C35.

4. On the Properties palette, select UPPER FL for Level and enter 0 for Offset from Level.

5. On the ribbon, click Boundary Line.

6. Click Pick Lines. On Option bar, enter 0 for Offset and check Lock to lock the slab boundaries to the picked lines.
7. Pick lines to sketch the boundaries of the slab.

![Figure A7.7](image1)

8. Use the modifying tools in Modify panel to adjust the boundary lines to form a close loop.

9. On the ribbon, click Mode panel ➤ Finish Edit Mode to finish.

![Figure A7.9](image2)

10. Click “No” for Revit prompt appeared. See Figure 9.

Good Practices:

1. It is advised to define slab boundaries using center lines of walls and beams. Otherwise, there are unintended cantilever slabs created beyond the supports or the slabs will become unsupported in the analytical model.

2. Sketch slab one by one instead of on slab for whole floor. Such that Slab Span symbols can be added for individual slabs.

Placing Sunken Slabs

Purpose:
To add sunken slabs.

Steps:
1. Roll the mouse wheel to zoom the area concerned. The sunken slab is assumed to be 145 mm thick.

2. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Structural Floor.

3. In the Type Selector select a structural floor type, say S145C35.

4. On the Properties palette, select UPPER FL for Level and enter -55 for Offset from Level.

5. On the ribbon, click Boundary Line.

6. Click Pick Lines. On Option bar, enter 0 for Offset and check Lock to lock the slab boundaries to the picked lines.

7. Pick lines to define the right and bottom boundaries of the sunken slab. See Figure 11 (a).
   (Tips: The first line you draw will show with a symbol. It indicates the span direction of the slab. Span direction is only meaningful for one slab and can redefine later if one wants.)
8. On Option bar, enter 55 for Offset. Define the rest of the boundaries of the sunken slab.

9. Use the modifying tools in Modify panel to adjust the boundary lines to form a close loop.

10. Click Mode panel ➤ ✔️ Finish Edit Mode to finish.

11. Place also other floor slabs inside the flat unit. And proceed to all other flat units.

Modifying Floor Slabs Properties

Purpose:
To change the properties of already placed slabs e.g. thickness & concrete mix.

Steps:
1. Select the slab required to change its properties.
2. On the Properties palette, select any other family type from the Type Selector drop-down.
3. If the required family type does not appear in the list, see *Creating New Slab Types* to create new floor type.

**Modifying Floor Slabs Boundary**

**Purpose:**
To change the layout of a floor slab panel.

**Steps:**
1. Select the slab required to change.

2. Click Modify | Floors ➤ Mode panel ➤ Edit Boundary.

3. Right click and hold boundary line to relocate it or the line end to change the length and orientation of the selected boundary line.

4. Use the tools in the Modify | Edit Boundary ➤ Draw to add new boundary lines.

5. Use the modifying tools in Modify panel to adjust the boundary lines to form a close loop.

6. Click Mode panel ➤ ✔️ Finish Edit Mode to finish.
Creating Filter for Checking Slab Thickness on a Framing Plan

Purpose:
To create filters which provide a way to display slab of different thickness in different color.

Steps:
1. Click View tab ➤ Graphics panel ➤ (Filter).
2. In the Filters dialog, if the required slab filter has already existed, the procedure completed. Click OK to exit. Otherwise continue the following steps.
3. In the Filters dialog, click New.
4. Enter , say, “Slab 145” for Name. Click OK

5. Under Categories, click Floors.

6. From the Filter By list under Filter Rule, select Description.
7. Select the filter operator “equals”.

Figure A7.15

Figure A7.16
8. Enter value 145 for the filter
9. Click OK twice.
10. Repeat the above steps to create more filter of all required slab thickness.

Applying Filters for Checking Slabs Thickness on a Framing Plan

Purpose:
To check slabs thickness by means of their display color.

Note:
1. Filter is view specific.
2. For facilitating user to view clearly, it is advised to hide the imported CAD file:
   Type VG (shortcut key for Visibility/Graphic) to open the Visibility/ Graphics dialog. Select Imported Categories tag. Unchecked the GBP CAD file to make it invisible. Click OK.

Steps:
1. Click View tab ➤ Graphics panel ➤ Visibility/Graphics, and click the Filters tab.
2. On the Filters tab of the Visibility/Graphic Overrides dialog, click Add. If the required filters are already present, click OK to skip the following steps.
3. Select a filter, say “Slab 145” from the Add Filter dialog, and click OK.

4. Click Override under Projection/Surface Patterns field of the added filter.

5. Change Color and Pattern in the Fill Pattern Graphics dialog as appropriate. Click OK.

6. Repeat Steps 3 to 5 until all slab filters have been added.

7. Check the Transparent of all unused filter e.g. those for walls. Click OK to finish.
Good Practices:

1. Users are advised also to check their work in 3D view & different elevation views to ensure the slabs have been placed in the correct levels.

2. User can save their View Template for future use. Select View tab ➤ Graphics panel ➤ View Template drop-down ➤ Create template from Current View.

3. On the New View Template dialog, enter, say, “Filter” for Name. Click OK twice to finish.

Figure A7.21 Plan view with slabs filters applied.
Disabling Applied Filters After Checking Slabs Thickness

Purpose:
To disable the applied slabs filters.

Notes:
The following steps are applicable for solid fill pattern have been select for filter color only.

Steps:
1. Click View tab ➤ Graphics panel ➤ (Visibility/Graphics), and click the Filters tab.
2. Check Transparent for all filters. Click OK.

Figure A7.22

Slab Marks

Purpose:
To add slab marks to individual slabs.

Notes:
1. HD standard Span Direction Symbol family has been loaded.

Steps:
1. Select the slab.
2. On the Properties Palette, enter text for Mark. Click Apply.

![Figure A7.23](image)

3. Alternatively, if Span Direction symbol with slab thickness is already there, double click the slab thickness. On the Change Parameter Values dialog, enter Value for Mark. Click OK to finish.

![Figure A7.24](image)

Note:
Slab Marks will be used during scheduling.

**Placing Slab Span Direction Symbol**

**Purpose:**
To place Span Direction symbol to floor slabs.

**Notes:**
1. HD standard family for Span Direction symbol has been loaded.
2. Span Direction symbol should be placed automatically on each slab as you placing the slabs.

Steps:
1. Place span direction symbol:
   i. Click Annotate tab ➤ Symbol panel ➤ Span Direction.
   ii. Select Auto place on the Options bar.
   iii. In the Type Selector select a span direction type.
   iv. Click a structural floor to place the direction span.

Editing Span Direction Symbol

Purpose:
To edit span direction symbol to floor slabs.

Steps:
1. To change Span Direction type:
   i. Select the symbol.
   ii. Select another family type in the Type Selector.
2. To change location:
   Right click and hold the symbol, drag to new location.
3. To redefine span direction:
i. Select the slab floor.

ii. Click Modify | Floors ➤ Mode panel ➤ Edit Boundary.

iii. On the ribbon Click Draw panel ➤ Span Direction.

iv. User can either pick line or draw line to define the span direction by using the appropriate tool on the Draw panel.

![Figure A7.27](image)

v. Click Finish Edit Mode to finish.

4. Alternatively, to align Span Direction perpendicular to a line:

i. Select the Span Direction symbol.

ii. Click Modify | Span Direction Symbol tab ➤ Align Symbol panel ➤ Align Perpendicular.

iii. Select a structural floor boundary, beam, or grid line to which the span direction will be perpendicular.

5. To hide the Label for thickness:

i. Select the Span Direction symbol.

ii. On the Properties Palette, click Edit type.

iii. On the Type Properties dialog, click Duplicate.

iv. On the Name dialog, enter text, say, “Two Way Slab (3 Supports) - 4mm No Thk” for Name. Click OK.

v. On the Type Properties dialog, uncheck “Two Way Mark+Thk” or “One Way Mark+Thk” and check “Two Way Mark” or “One Way Mark”. Click OK.

![Figure A7.28](image)

6. To relocate the Mark and/or thickness label:

i. Select the Span Direction symbol.
ii. On the Properties Palette, click Edit type.

iii. On the Type Properties dialog, click Duplicate.

iv. On the Name dialog, enter text, say, “Two Way Slab (3 Supports) - 4mm No Mk & Thk” for Name. Click OK.

v. On the Type Properties dialog, uncheck all parameters for Text. Click OK.

vi. Place an additional Span Direction symbol of type either “Mark only” or “Mark + Thk only” as appropriate to the slab. See Placing Slab Span Direction Symbol.

vii. Select the newly placed symbol, drag it to a new location and rotate it by using the Modify tool on the ribbon if needed.

Modifying the Presentation of Slabs Boundaries

Purpose:
To eliminate the solid line around the slab boundaries and its supporting elements including beams, slabs and wall.
Steps:
1. Click Modify tab ➤ Geometry panel ➤ Join drop-down ➤ Join Geometry.
2. On Option Bar, select Multiple Join.
3. Select the first geometry to join (for example, a slab).
4. Select the second geometry to join to the first (for example, supporting wall, beam or adjacent slab), continue selecting other geometry to join to the first.
5. To exit the tool, click Modify on the ribbon or press Esc.

Overriding Boundary Line Types

Purpose:
To change the line types of common boundary of two slabs to that
required type in case joining of the slabs does not help changing the solid line to hidden line i.e. short dash line.

Good Practices:
It is may be helpful to work on with the filers for walls and slabs switching on.  See Applying Filters for Checking Slabs Thickness on Framing Plan.

Steps:
1. Click Modify tab ➤ View panel ➤ Linework ➤ Line Style drop-down.  Select appropriate line style, say, <Invisible lines>.

2. Click the slab boundary line(s) required to change to the selected style.  (Tips: for line at slabs common boundary, it is required to click the line twice.)

3. To exit the tool, click Modify on the ribbon or press Esc.
Tips:
In some cases the process causes some lines become invisible. To compensate the error, user can draw detail lines manually at that locations, *Revit Structure User Guide* refers.

Placing Symbol for Level Different

Purpose:
To place symbol “level different” at drop level location say sunken bath.

Preparation:
The HA customized symbol family should be already loaded into the HA standard template if not user should load the family into the project before carrying out the following steps. *Revit Structure User Guide* refers.

Steps:
1. Zoom to the location where the symbol required to place.
2. Click Annotate tab ➤ Symbol panel ➤ 🟢 (Symbol).
3. In the type selector, select the symbol type for “Level Different”.

*Figure A7.36 Overriding line types*
4. Place the symbol(s) by selecting the line(s) showing the level drop. Click Modify to finish.

5. Input the value of level different by selecting the symbol. Click the question shown on the symbol. Enter a value into the text box. Enter to finish.

6. To modify the symbol e.g. flip and rotate…etc, select the
symbol. Use the Modify tools shown on the ribbon to make the changes.

![Figure A7.40](image)

**Placing Opening**

**Purpose:**
To place small opening on the floor as per GBP e.g. refuge chute.

**Preparation:**
To switch on the visibility of the GBP: type VG. On the Visibility dialog, click Imported Categories tab. Check the check box beside the GBP file name. Click OK.

![Figure A7.41](image)

**Steps:**
1. Zoom to the location where opening is required.
2. Click Home tab ➤ Opening panel ➤ By Face.
3. Select a structural floor.
4. Using the sketch tools on the Modify | Create Opening Boundary tab ➤ Draw panel, sketch the boundaries of floor
opening.

4 When finished, click Modify | Create Opening Boundary tab ➤ Mode panel ➤ Finish Edit Mode.

Making Slab Edges in Walls Invisible

Purpose:
To make slab edge lines embedded inside a wall invisible by placing solid fill above the wall.

Steps:
1. Zoom to the wall.
2. Click Annotate tab ➤ Details panel ➤ Region drop-down ➤ Filled Region.
3. On the Properties palette, click Edit Type.
4. On the Type Properties dialog, click Duplicate.
5. In the Name dialog, enter a new name say “Solid Gray”. Click OK.
6. In the Type Properties dialog, select “Solid fill” for Fill Pattern and gray for Color. Click OK

![Type Properties Dialog]

7. In the Modify | Create Filled Region Boundary tab ➤ Draw panel, select ✂️ Pick Lines.

8. In the Modify | Create Filled Region Boundary tab ➤ Draw panel ➤ Line Style panel, select Medium Line.

9. Draw the boundaries for solid fill around a wall. Click ✅ to finish.

![Figure A7.45]

10. Click Modify to exit Create Filled Region Boundary mode.

![Figure A7.46]

Good Practices:
It is preferably to draw Filled Region for individual walls by separated operation such that it will more simple for future
modification process.

Loading Fill Pattern

Purpose:
To load the customized hatch pattern for, for instance, precast area.

Prerequisite:
Identify the location of the HD standard patterns file (*.pat) in the HD BIM library otherwise prepare the pattern file.

Notes:
HA standard Fill Pattern should have been loaded into the project template file.

Steps:
1. Click Manage tab ➤ Settings View panel ➤ 📋 Additional Settings drop-down ➤ 🟨 Fill Patterns.
2. In the Fill Patterns dialog, select Drafting for Pattern Types. Click New afterward.
3. In the New Pattern dialog, select Custom and click Import.

Figure A7.47
4. In the Import Fill Pattern dialog, browse to select the pattern file. Click Open.

5. In the New Pattern dialog, select the required pattern in the Custom box. Click OK twice to exit.
Overlaying Fill Region

Purpose:
To add hatching over bathroom area and precast staircase on plan.

Prerequisite:
The required Fill Pattern should have been loaded into the project otherwise user should refer to Loading Fill Pattern.

Preparation:
To switch on the visibility of the GBP: type VG. On the Visibility dialog, click Imported Categories tab. Check the check box beside the GBP file name. Click OK.

Steps:
1. Click Annotate tab ➤ Detail panel ➤ Filled Region drop-down ➤ Filled Region.
2. In the Properties palette, click Edit Type.
3. If the required type already exist, select it and skip to step 9 otherwise follow the step below.
4. In the Type Properties dialog, click Duplicate.
5. In the Name dialog, type a name for the new Fill Region Type, say “HD Bathroom Area”. Click OK to finish.
6. Select the value for Fill Pattern. Click the small button on the right.
7. In the Fill Pattern dialog, select the suitable pattern and click OK to exit. Select Draft for Pattern Type. If the required pattern does not exist, click New and refer to *Loading Fill Pattern for Bathroom Area* to load the fill pattern(s).

8. Change Background to Transparent and Line Weight to 1. (Line Weight 1 is equivalent to pen size 0.18mm as preset in the HD project template) and Color to Black. Click OK to finish.

9. To make the outline of the Filled Region with dash line, on the ribbon, select Line Style panel ➤ Line Style: drop-down ➤ <Hidden > (or any other type as appropriate).

10. To define the extent of Filled Region, on the ribbon, use the Draw panel tools together with those in Modify panel.

11. On the ribbon, click Modify panel ➤ ✔ Finish Edit Mode to finish.
Good Practices:
It is preferably to made fill regions one by one otherwise if one of the fill region is changed/deleted then it will be apply to all.

Edit Fill Region – Pattern Scale

Purpose:
To change the fill pattern density of a fill region.

Notes:
This guideline is only applicable for Custom fill pattern. For Simple one, user can refer to Rivet Structure User’s Guide.

Steps:
1. Select one of fill region want to change the fill pattern density.
2. On the Properties palette, click Edit Type.
3. In the Type Properties dialog, select to active the button on the right of the value for Fill Pattern. Click the button.
4. In the Fill Pattern dialog, click Edit.
5. In the Modify Pattern Properties dialog, click Import.
6. In the Import Fill Pattern dialog, browse to and Select the fill pattern file that fill pattern imported from.
7. Adjust the Import Scale. Change the Name also if necessary. Click OK three times to finish.

**Edit Fill Region – Fill Pattern**

**Purpose:**
To change the fill pattern of a fill region.

**Notes:**
This guideline is only applicable for the Custom fill pattern. For the Simple one, user can refer to *Rivet Structure User’s Guide*.
Steps:
1. Select one of fill region want to change the fill pattern.
2. On the Properties palette, click Edit Type.
3. In the Type Properties dialog, select to active the button on the right of the value for Fill Pattern. Click the button.
4. In the Fill Pattern dialog, click Edit.
5. In the Modify Pattern Properties dialog, click Import.
6. In the Import Fill Pattern dialog, browse to and Select the fill pattern file that fill pattern wanted to be imported from.
7. Select the required fill pattern. Click OK three times to finish.

Edit Fill Region – Boundaries

Purpose:
To change the boundaries line type of a fill region.

Steps:
1. Select one of fill region want to change the boundary line type.
2. On the ribbon, click Mode panel ➤ Edit Boundary.
3. Select the lines for changing to another line type.
4. On the Properties palette, select the appropriate line type from the Subcategory drop-down list.

![Figure A7.60](image)

5. On the ribbon, click Modify panel > ✅ Finish Edit Mode to finish.
ANNEX VIII – Inclined Slab

Objective

To create inclined a structural floor slab by editing its shape instead of specifying its slope in the boundaries edit mode.

Good Practices

If we modeled the slab by means of the combination of different elements with different gradient fall, the resulting slab may become structurally unsupported.

Prerequisite

1. The details of the slab gradient at different locations.
2. The HD SE Revit family of the Structural Floor in which the family type has been defined with single concrete core layer only in which the parameter “Variable” was not selected. (The standard family should have been loaded into the HD standard project template. Or it has been saved in the SE BIM
Edit the Shape of the Slab

1. Place a slab element into the model.
2. Switch to any plan view of the slab and click to select it.

3. In the ribbon, click Modify > Floor tag ➤ Shape Editing ➤ Add Split Line. Draw the split lines with the aid of Modify tools at any required locations. Click Modify to escape from the Add Split Line mode.

4. Switch to 3D view, select the slab.

5. Click Modify > Floors tag ➤ Shape Editing panel ➤ Modify Sub Elements.

6. Select the middle split line, click the figure between blue up and down arrow near the selected split line. Enter 500 to input area shown. Click Enter key to finish.
7. Click Enter to escape. On the ribbon, click Modify to finish.

8. In case the Split Lines are embedded inside the slab supporting element. Modeler can edit the Split Lines provided that the supporting element is temporary hidden from the current view.
ANNEX IX - Slab with Top Fall

Objective

To construct a structural floor slab with level fall on top face, this kind of elements are mostly found in a/c hood and canopy in a building.

Prerequisite

1. The details of the element.
2. The HD SE Revit family of the Structural Floor in which the family type has been defined with single concrete core layer only in which the parameter “Variable” was not selected.
   (The standard family should have been loaded into the HD standard project template. Or it has been saved in the SE BIM library.)

Modify the Existing Family Type

1. Place a slab element into the model.
2. Right mouse click to select the element.
3. In the Properties Palette, click Edit Type.

4. In the Type Properties dialog, click Duplicate to create a new Type.

5. In the Name dialog, enter a name for the new Type. And click OK button to exit.

6. In the Type Properties dialog, click the Edit button for Parameter “Structure”.

7. In the Edit Assembly dialog, check the box under Variable of layer “Structure”.

8. Click OK twice to finish.
Editing the Shape of the Slab

1. Switch to any plan view of the slab and click to select it.

2. In the ribbon, click Modify ➤ Floor tag ➤ Shape Editing ➤ Add Split Line. Click to enter the split line start at any point close to the intended location of the split line. Similarly, click to enter the split line end.

3. To align the split with the wall surface, click Modify ➤ Floors tag ➤ Modify panel ➤ Align. Select the wall surface then the newly created split line.

4. On the ribbon, click Modify to finish.

5. Switch to 3D view, select the slab.

6. Click Modify ➤ Floors tag ➤ Shape Editing panel ➤ Modify Sub Elements.

7. Select the split line, click the figure between blue up and down.
arrow near the selected split line. Enter 40 to input area shown. Click Enter key to finish.

Figure A9.10

8. Select the wall supporting the slab. In the View Control bar, click Hide Element. The wall will become temporary invisible.

Figure A9.11

9. Select the slab.

10. Click Modify | Floors tag ➤ Shape Editing panel ➤ Modify Sub Elements.

11. Select the slab boundary that actually embedded inside the wall. Click the figure between blue up and down arrow near the selected boundary line. Enter 40 to input area shown. Click Enter key to finish.

Figure A9.12

12. In the View Control bar, click Reset Temporary Hide/Isolate. The wall will become visible again.

13. On the ribbon, click Modify to finish.
ANNEX X – Slabs Joint

Objective

To demonstrate how to make a chamfer at the joint bottom between two slabs which are of different thickness.

Before adding chamfer

After adding chamfer

(a)
(b)

Figure A10.1

Unjoining the Slab

In case the concerned slab has already joined with surrounding elements, slab edge can not be added to the slab. User should unjoin it with its adjacent elements.

Step:

1. Click Modify tab ➤ Geometry panel ➤ Join Geometry drop-down ➤ Unjoin Geometry.

Figure A10.2

2. Select the slab to be unjoined from the adjacent elements.
Slab joined with other elements

Slab unjoined from other elements

(a)

(b)

Figure A10.3

Loading Slab Edge Profile Family

The slab edge profile defines the chamfer profile. User should load the HA customized slab edge profile family into the project before he can use it.

Steps:

1. Click Insert tab ➤ Load from Library panel ➤ Load Family.
   In Load Family dialog, navigate to the directory of family library. Open the profile family file.

Adding Slab Edge Profile Family Type

The slab edge profile dimensions define the chamfer dimensions.
Steps:

1. Check whether the family type with suitable chamfer dimensions is available. In the project browser, expand the profile family loaded under the category Profiles. Skip this topic if the required one is already present.

2. Add profile family types. Right click one of the loaded slab edge profile family type in the project browser. Select Duplicate.

3. Enter a new name, say “120mm 60deg Chamfer”, to the text box and press Enter.

4. Double click the newly created family type.
5. In the Type Properties dialog, enter the required value for parameters Thickness and Chamfer Angle. Click OK to finish.

![Figure A10.8](image)

**Adding Slab Edge to Floor Element**

To add chamfer slab edge to the slab drop.

**Steps:**

1. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Slab Edge.
2. Click Edit Type in the Properties Palette.
3. Select the required Profile type and concrete grade for Material in the Type Properties dialog.
4. In the Properties Palette, enter a value for Vertical Profile Offset. (Note: It should be equal to the negative value of the thinner slab at the slab drop.)

5. Click to select the slab edge to place the chamfer.

6. Click OK to finish.
7. Click Unjoin Elements for the any warning prompt appeared.

8. Click the double arrow beside the slab edge if the slab edge is located on the wrong side of the slab edge. Keeps the slab
edge being selected.

![Figure A10.13](image)

9. In the Properties Palette, correct the value to say -180 for Vertical Profile Offset if it is reset to 0.0 by the software. Click Apply.

10. Make an orthogonal section view across the slab junction and go to the view.

![Figure A10.14](image)

11. To remove the unwanted line in the sectional view. Click Modify tab ➤ Geometry panel ➤ Join Geometry drop-down ➤_JOIN Geometry. Select the required elements to join. Click Modify in the ribbon to finish.

![Figure A10.15](image)

12. Go to the corresponding plan view.
13. To join the slab back to the adjacent elements. Click Modify tab ➤ Geometry panel ➤ Join Geometry drop-down ➤ 🎨 Join Geometry. Select the required elements to join. Click Modify in the ribbon to finish.
ANNEX XI – Precast Stair Flight

Objective

To place a precast stair flight to a BIM Model.

Prerequisite

1. Supporting beams to the precast stair flight have been already place into the model.
2. Architectural AutoCAD GBP linked to required level.

Loading Stair Tags and Run Direction Symbol (Startup of a project)

Purpose:
To load the HA customized stair tags and run direction symbol family into the project.

Note:
The HA customized stair tags and run direction symbol family span direction symbol family should be already loaded into the HA standard template.

Steps:
1. Click Insert tab ➤ Load from Library panel ➤ Loaded Family.
2. On the Load Family dialog, navigate to the directory of the family file. Select the family file and click Open to complete the process. The updated HA standard family list refers.
Creating New Stair Types

Purpose:
To create new stair types with required properties including landing and waist thicknesses and concrete grade if they are not existed. Also customize them to suit B(P)R and Housing standard.

Note:
1. Stair is a system family that means no family file can be created.
2. A standard stair type have already made in the HD standard project template. User can duplicate it and change it to the required type.
3. The following stair types are required for our case:
   (195+40) mm thick landing and 160 mm thick waist with C35 concrete;
4. Don’t use the Calculate Rules.

Steps:
1. Open the project model or template.
2. In Project Browser, browse to the Stairs family.
3. Right click the Monolithic Stair and select Duplicate. A new family type named Monolithic Stair2 created.

4. Double click the Monolithic Stair 2.
5. In the Type Properties dialog, select Monolithic Stair 2 and click Rename.
6. In Rename dialog, enter a new type name say “HD RC Stair C35 235L160W”. Click OK.

7. Input - 235 into Extend Below Base i.e. base landing thickness.
8. Change Landing Overlap to 0.
9. In Monolithic Material, click \(\text{material}\) to select, say, grade C35 concrete.
10. Change Minimum Tread Depth to 225. (B(P)R)
11. Change Noising Length to 15. (HD standard)
12. Change Maximum Riser Height to 175. (B(P)R)
13. Uncheck Begin with Riser.
14. Change Stringer and Landing Carriage Height to 160 and 235 respectively (i.e. the waist and upper & half landing thickness).
15. Enter thickness of the waist, say 160, for Description. Click OK.

Placing Staircases

Purpose:
To add a flight RC staircase to the project.

Prerequisite:
Collect the following data before proceeding to the step below:
For our case
i. Stair Width = 1400 mm for our case;
ii. Desired Number of Risers = 8;
iii. Actual Tread Depth = 225mm.

Note:
To switch on the visibility of the GBP: type VG. On the Visibility
dialog, click Imported Categories tab. Check the check box beside the GBP file name. Click OK.

Steps:

1. Click Home tab ▶ Circulation panel ▶ 🏨 Stairs.

2. In the ribbon, select 🏨 Railing Type. In the Railing Type dialog, choose None. Click OK.

3. In Properties palette, click ☑️ Edit Type.

4. In Type Properties dialog, select the appropriate stair type or the one created previously. Click OK to exit.

5. In the Properties palette, input the Constraints and Dimensions for the staircase. Click Apply (Note: This may not necessary if the Apply button has automatically been dim).
Figure A11.8

6. On the ribbon, click Draw panel ➔ Run and ✖️ Line.
7. Right click to select a point for the start of base landing.
8. Right click to select a point for the end of top landing.

![Diagram showing points for start of base landing and top landing](image)

Figure A11.9

9. In case error prompt “Line too short” appears, click Cancel. Repeat steps 7 and 8 but with any other point as the end of the top landing until no error occurs.

10. On the ribbon, click Mode panel ➔ ✔️ Finish Edit Mode to finish.

Note:
The above steps will only create the approximate layout of the stair. However, we will correct the layout later, see *Modifying Stair Layout*

**Modifying Stair Layout**

**Purpose:**
To change the layout of stair including orientation, boundaries and no. of risers.

**Steps:**
1. Select the stair. On the ribbon, click Mode panel ➔ Edit Sketch.
2. To change the orientation of the stair, switch to the corresponding plan view. Select the stair, click the flip control arrow to change the orientation.

3. To align the base/top landings to decided locations: On the ribbon, click Modify panel ➤ Align. Select the lines for the landings to be aligned with, followed by selecting the landing lines generated by Revit. On the ribbon, click Select panel ➤ Modify to finish.

4. To align the boundaries locations: On the ribbon, click Modify panel ➤ Align. Select the lines for the boundaries to be aligned with, followed by selecting the boundaries lines generated by Revit. Sometimes users may require trimming the risers to the relocated boundaries. On the ribbon, click Select panel ➤ Modify to finish.

5. To delete the unnecessary risers generated by the software, select the riser and press Delete button on keyboard. On the
To add risers to the stair: On the ribbon, click Draw panel ➤ Riser and Line. Draw line for the required riser. On the ribbon, click Select panel ➤ Modify to finish.

7. To align the risers to those shown on the architectural drawing:

On the ribbon, click Modify panel ➤ Align. Select the riser line in the architect drawing and then the riser line of the BIM model. On the ribbon, click Select panel ➤ Modify to finish.

8. On the ribbon, click Mode panel ➤ Finish Edit Mode to finish.

Good Practices:
1. To create stairs flight by flight.
2. Every time after creating and editing a stair, it is advised to check the staircase configuration by means of 3D-View and sectional views made along the stair flights. In the sectional views, measure the stair dimensions by means of the measuring tools in the Modify tab ➤ Measure panel.

![Figure A11.12](a) ![Figure A11.12](b)

Modifying Stairs Properties
Purpose:
To change the properties of stairs.

Steps:
1. To change the thickness of landings, waist and concrete mix, create a new stair type if the decided family type does not exist, Creating New Stair Types refers.
2. Then select the stair and change to the new/another family type in the Type Selector.

Adding Stair Marks

Purpose:
To add stair marks to individual flight.

Notes:
HD standard Stair Tags family should be loaded.

Steps:
1. Select the stair.
2. On the Properties Palette, enter text for Mark. Click Apply.

3. Alternatively, if Stair Tags with stair mark is already there, double click the tag. On the Change Parameter Values dialog, enter Value for Mark. Click OK to finish.
Note:
Stair Mark will be used during scheduling.

Placing Stair Tag

Purpose:
To place stair span direction symbol to stair.

Notes:
Housing standard family for Stair Tags should be loaded.

Steps:
1. Place span direction symbol:
   v. Click Annotate tab ➤ Tag panel ➤ Tag by Category.
   vi. Uncheck Leader on the Options bar.
   vii. Select the stair for placing the tag.
   viii. On the ribbon, Click Select panel ➤ Modify to end the Tag mode.
2. Drag the tag to the required location.

3. On the ribbon, Click Select panel Modify to end the Stair Tag mode.

Editing Stair Tag

Purpose:
To change/edit span direction of the tag.

Steps:
1. Select the stair tag.
2. In the Type Selector, change to another a stair tag family.

3. Drag the tag to the required location.
4. On the ribbon, click Select panel ➤ Modify to complete.

Shifting the Break Symbol

Purpose:
To shift the break symbol for showing more raisers on plan.

Steps:
1. In project browser select the corresponding plan view.
2. In the Properties palette, click Edit to edit the View Range.
3. In the View Range dialog, change the Offset values for Top & Cut plane. Click OK to finish.

Figure A11.19

(a) Top Offset = 1500
Cut Plane Offset = 100

(b) Top Offset = 1500
Cut Plane Offset = 1000

Figure A11.20
Placing Up/Down Arrow

Purpose:
To place an HD standard Up/Down arrow on the stair.

Notes:
Housing standard Run Direction symbol family has been loaded into the project otherwise *Loading Stair Tags and Run Direction Symbol* refers.

Steps:
1. Select the concerned stair. In the Properties palette, uncheck all options under Graphics group. Click Apply to finish.

   ![Figure A11.21](image1)

2. Click Annotation tag ➤ Symbol panel ➤ Symbol.

3. In the Type Select choose the required symbol type.

   ![Figure A11.22](image2)

4. Place the symbol at the mid-point of first riser. Click Modify in the ribbon to finish.
5. To align the arrow to center of the stair, click Annotation tag ➤ Detail panel ➤ Detail Line. Then draw a line from the mid-point of one riser to that of any other riser. Align the arrow symbol to that detail line and delete the line afterward.

Configuring the Up/Down Arrow

Purpose:
To configure the Up/Down placed on stair.

Steps:
1. Select the Up/Down arrow.
2. In the Properties palette, change the parameters and check/uncheck the available options. Click Apply to finish.
Placing Non-Shrink Grout between Staircases

Purpose:
To fill up the gap with non-shrink grout between the staircases.

Prerequisite:
1. Material for the non-shrink grout should be created if it is not found in the project template library.
2. Floor slab composite of non-shrink grout should be made if it is not found in the project template library.

Steps:
1. Click Home tab ➤ Structure panel ➤ Floor drop-down ➤ Structural Floor.
2. In the Type Selector choose a floor type, say Non-Shrink Grout 235Thk C35.
3. On the Properties palette, select UPPER FL for Level and enter 0 for Offset from Level. Uncheck the check box for Structural.

4. Follow the steps for *Placing Floor Slab*.

![Figure A11.27](image)

5. Delete the slab span direction symbol if it appears.

---

**Overriding Line Types**

**Purpose:**
To change the line types of risers for framing plan production.

**Steps:**

1. Click **Modify tab ➤ View panel ➤ Linework ➤ Line Style drop-down**. Select appropriate line styles e.g. Lines for risers, <Invisible lines> for beam flange and Hidden lines for beam top.

2. Click the lines needed to change styles.

3. To exit the tool, click **Modify on the ribbon or press Esc**.
4. Also add details lines as necessary.

Loading Fill Pattern for Precast Staircase

Purpose:
To load the customized hatch pattern for HD precast staircase.

Prerequisite:
Identify the location of the HD standard patterns file (*.pat) in the HD BIM library otherwise prepare the pattern file.

Notes:
Housing standard Fill Pattern for precast staircase should have been loaded into the project template file.

Steps:
1. Click Manage tab ➤ Settings View panel ➤ Additional Settings drop-down ➤ Fill Patterns.
2. In the Fill Patterns dialog, select Drafting for Pattern Types. Click New afterward.
3. In the New Pattern dialog, select Custom and click Import.

4. In the Import Fill Pattern dialog, browse to select the pattern file. Click Open.
5. In the New Pattern dialog, select the required pattern in the Custom box. Click OK twice to exit.
Overlaying Fill Pattern on Precast Staircase

Purpose:
To add hatching over precast staircase on plan.

Prerequisite:
The required Fill Pattern should have been loaded into the project otherwise user should refer to *Loading Fill Pattern for Precast Staircase*.

Steps:
1. Click Annotate tab ➤ Detail panel ➤ Region drop-down ➤ Filled Region.
2. In the Properties palette, click Edit Type.
3. If the required type already exist, select it and skip to step 9 otherwise follow the step below.
4. In the Type Properties dialog, click Duplicate.
5. In the Name dialog, type a name for the new Fill Region Type, say “HD Precast Staircase”. Click OK to finish.
6. Select the value for Fill Pattern. Click the small button on the right.

*Figure A11.33*
7. In the Fill Pattern dialog, select the suitable pattern and click OK to exit. If the required pattern does not exist, click New and refer to *Loading Fill Pattern for Precast Staircase* to load the fill pattern(s).

8. Change Background to Transparent for, Line Weight to 1. (Line Weight 1 is equivalent to pen size 0.18mm as preset in the HD project template) and Color to Black. Click OK to finish.

9. To make the outline of the Filled Region invisible, on the ribbon, select Line Style panel ➤ Line Style: drop-down ➤ <Invisible Lines>.

10. To define the extent of Filled Region, on the ribbon, use the Draw panel tools together with those in Modify panel.

11. On the ribbon, click Modify panel ➤ ✔ Finish Edit Mode to finish.
Notes:
For editing Fill Region, user can refer to the corresponding sub-topic in Slabs.
ANNEX XII – Precast Facades

Objective

To add precast façade to the BIM model of a typical floor according to architectural design.

Good Practices

The typical floor used in the procedures below is composed of HA standard modular flats, so all precast façades used are also standard types.

Prerequisite

1. Revit project with slabs, beams, columns and walls added.
2. Architectural AutoCAD GBP linked to required level.
3. Façade type for each flat should be referred to architect’s design.

Loading Precast Façade Families and Annotation Tag

Purpose:
To load the HA customized precast façade and corresponding annotation tag families into the project.

Note:
The HA customized families should be already loaded into the HA project standard template.

Steps:

1. Click Insert tab ➔ Load from Library panel ➔ Loaded Family.
2. On the Load Family dialog, navigate to the directory of the family file. Select the family file and click Open to complete the process. The updated HA standard family list refers.

![Figure A12.1](image1)

![Figure A12.2](image2)
Placing Precast Facades

Purpose:
To add a precast façade to the typical floor model.

Prerequisite:
The distribution of different façade types, namely, T1, T2, T2a, T3, T4, T5 & T6.

Note:
1. To switch on the visibility of the GBP: type VG. On the Visibility dialog, click Imported Categories tab. Check the check box beside the GBP file name. Click OK.

2. Change the Detail level to Medium on the View Option Bar during placing the facades. Change it back to Coarse level afterwards

Steps:
1. Change to appropriate Structural Plans view, say UPPER FL.
2. Click Home tab ➤ Model panel ➤ ☐ Component drop down ➤ ☐ Place a Component.
3. In the Type Selector, choose the required façade family and type, say T1
4. Place the façade at the designated location, press spacebar to rotate it if necessary. On the ribbon, click Modify to escape the Place mode.

5. Select the façade. On the Properties palette, change the Top Level to working floor and Base Level to that below. Change both the Top and Base Offset to 0.00.

6. To change the orientation of the façade, select the façade. Use the flip controls ( and/or ) beside the façade and the Modify tools to adjust it’s alignment. On the ribbon, click Modify to finish.
7. Repeat steps 2 to 6 until all facades are placed.

Good Practices:
3. It is advised to check the orientation of each façade in 3D-View mode after placing them.

Editing Precast Facades

Purpose:
To modify the width of precast façade which is wider than that in standard design.

Steps:
1. Measure the gap between the façade edge and the wall side. Type “di”. Select the corresponding lines, click anywhere outside the dimension. On the ribbon, click Modify to finish.

2. Select the façade concerned.
3. In the Properties palette, click Edit Type.
4. In the Type Properties dialog, click Duplicate. In the Name dialog, type in a new Type Name, say “T1a”. Click OK.
5. In the Type Parameter box, type, say 100 for Extension b (or Extension a as required).
6. Type the revised the contents for Model and Description as necessary. Click Apply and OK.
7. Check the result. If it is correct, delete the unnecessary dimension made in step 1 otherwise redo steps 2 to 6.

Changing Façade Type

Purpose:
To change façade type.

Steps:
1. Select the façade concerned. On the Type Selector, choose the required façade type.
2. Flip, edit and/or align the façade element as necessary. On the ribbon, click Modify to accept the change.

Placing Façade Type Marks

Purpose:
To place type marks to the standard precast façade.

Prerequisite:
1. HD standard family for Facade Tags should have already been loaded.
2. Switch to corresponding plan view.

Steps:
4. Click Annotate tab ➤ Tag panel ➤ Tag by Category.
5. Uncheck Leader on the Options bar.
6. Select the facade for placing the tag.
7. On the ribbon, Click Select panel ➤ Modify to end the Tag mode.
8. Drag the tag to the required location.
9. Press spacebar to switch its orientation between Horizontal and Vertical as necessary.
10. On the ribbon, Click Select panel ➤ Modify to end the Stair Tag mode.
ANNEX XIII – Annotations

Objective

To place lines, dimensions, center lines, tags and tie beams to a typical floor BIM model.

Adding Line Patterns

Purpose:
To add required line pattern to project.

Note:
1. This part is necessary only if the required line patterns are not found in the standard project template.
2. To show out the existing line patterns, click Manage tab ➤ Setting panel ➤ Additional Settings drop-down ➤ Line Patterns.

Steps:
1. Click Manage tab ➤ Setting panel ➤ Additional Settings drop-down ➤ Line Patterns.
2. On the Line Patterns dialog, click New.

Figure A13.1
3. On the Line Pattern Properties dialog, enter a new name (say "HD Center 6 mm) and pattern properties for the line pattern. Click OK to exit.

![Line Pattern Properties](image)

4. Repeat steps 2 to 3 to continue to define new line patterns and click OK to finish.

Customizing Line Styles

Purpose:
To customize line style in a project.

Notes:
1. This part is necessary only if the required line patterns are not found in the standard project template.
2. To show the existing line styles, click Manage tab ➤ Setting panel ➤ Additional Settings drop-down ➤ Line Styles.

Prerequisite:
The required line patterns have already been composted. For detail see Adding Line Patterns.

Steps:
1. Click Manage tab ➤ Setting panel ➤ Additional Settings
2. On the Line Styles dialog, click the line category from Category list for customization. Click the corresponding Line Pattern and select the required line pattern from the selection list. Repeat this procedure as necessary and Click OK to finish.

3. Alternatively, user can add new line categories by clicking the New inside the Modify Subcategories box.

4. On New Subcategory dialog, enter a name for new line style. Click OK.

5. On the Line Styles dialog, click the newly added line category from Category list. Click the corresponding Line Pattern and select the required line pattern from the selection list. Change to the required line weight. Repeat this procedure as necessary and Click OK to finish.
Figure A13.5

Placing lines

Purpose:
To place annotation lines on framing plan.

Prerequisite:
The required line styles have already been added. For detail see Adding Line Patterns and Customizing Line Styles.

Steps:
1. Click Annotate tab ➤ Detail panel ✏ Detail Line.
2. On the ribbon, click Line Style panel ➤ Line Style drop-down ➤ select the required line style.
3. On the ribbon, select suitable tool from Draw panel to draw the required lines.
4. On the ribbon, click Modify to accept the added lines.

Customizing Dimensions Arrowheads

Purpose:
To add required arrowhead style for dimensioning to a project.

Notes:
1. This part is necessary only if the required arrowhead styles are not found in the standard project template.
2. To check the existing arrowhead style, click Manage tab ➤ Setting panel ➤ Additional Settings drop-down ➤ Arrowheads.

Steps:
1. Click Manage tab ➤ Setting panel ➤ Additional Settings drop-down n ➤ Arrowheads.

2. On the Type Properties dialog, select one of the predefined arrowhead types which close to the required style. Click duplicate.

![Figure A13.8](image)

3. On the Name dialog, type in the new arrowhead type name. Click OK.

![Figure A13.9](image)

4. On the Type Properties dialog, modify the parameters and click OK to finish.

![Figure A13.10](image)

Customizing Dimension Styles

Purpose:
To add required dimension style to the project.

Notes:
1. This part is necessary only if the required dimension styles are not found in the standard project template.
2. To check the existing dimension styles, click Annotate tab ➤ Dimension panel ➤ select required dimension type.

![Figure A13.11](image1)

3. Click the type selector. Press Esc to exit.

![Figure A13.12](image2)

Prerequisite:
The required arrowhead type has already been added. For detail see *Customizing Dimensions Arrowheads*.

Steps:

1. Click Annotate tab ➤ Dimension panel ➤ select required dimension type.
2. On the Properties palette, click Edit Type.
3. Select, from the Type list, the family type which is close to the required one and click Duplicate.

4. On the Name dialog, enter the name for the new dimension type. Click Ok.

5. Change the Value of Parameters as appropriate. Click OK to finish.

Dimensioning

Purpose:
To place dimensions to plan view.

Steps:
1. Click Annotate tab ➤ Dimension panel ➤ select required dimension type. Alternatively, type “di” and skip to step 3.
2. In the type selector, select the appropriate family type.
3. Pick reference line or point according to the dimension type to be drawn.
4. Place the cursor on the desired location of the next reference point or line, and click.
5. User can continue to select multiple references, if desired.
6. When you have reached the last reference point, move the cursor away from the last component and click.
7. For details of all dimension types, refer to *Placing Permanent Dimensions* in Revit Structure 2011 User’s Guide.

**Adding Dimension Witness Lines**

**Purpose:**
To add witness line(s) for a chain dimension.

**Steps:**
1. Select the dimension.
2. Click Modify | Dimensions tab ➤ Witness Lines panel ➤ Edit Witness Lines.
3. Click the element for which you want to add a new witness line, and then click in the drawing area.
4. When you are finished, press Esc.

Deleting Dimension Witness Lines

Purpose:
To delete witness line(s) from a chain dimension.

Steps:
1. Select a dimension.
2. Click Modify | Dimensions tab ➤ Witness Lines panel ➤ Edit Witness Lines.
3. Click the witness line you want to delete from the chain dimension, and then click in the drawing area.
4. When you are finished, press Esc.
Loading Centerline Symbol

Purpose:
To load the HA customized centerline symbol into the project.

Note:
The HA customized families should be already loaded into the HA project standard template.

Steps:
1. Click Insert tab ➤ Load from Library panel ➤ Loaded Family.
2. On the Load Family dialog, browse to the directory of the family file. Select the family file and click Open to complete the process. The HA standard families list refers.

Placing Centerline Symbol

Purpose:
To place centerline symbol into a project.

Steps:
1. Click Annotate tab ➤ Symbol panel ➤ Symbol.
2. In the Type Selector, choose the required symbol type.
3. If the required symbol type is not found in the list, on the ribbon,
click  Loaded Family otherwise skip to step 5.

4. On the Load Family dialog, browse to the directory of the family file. Select the family file and click Open to complete the process. The HA standard families list refers.

5. Move the cursor to the designated location and click.

![Figure A13.21](image)

6. To rotate the symbol, on the ribbon, click Modify tab ➤ Rotate. Select or defined the start and end ray.

7. To move the symbol, click the symbol handle and drag to desired location.

8. Repeat steps 5 to 7 as necessary. On the ribbon, click Modify to finish.

9. To further change the location and orientation of the symbol, select it.

10. Use the Modify tools on the ribbon to modify the symbol. Click Modify to finish.

![Figure A13.22](image)

Placing a Text Note – Without Leader

Purpose:
To place a text note (without leader) into project.
Steps:

1. Zoom to the location where text notes are to be placed.
2. Click Annotate tab ➤ Text panel ➤ A Text.
3. Select on Modify | Place Text ➤ Format panel ➤ A No Leader and □ Left Align (or other as appropriate).
4. To select the font type, click the type selector. Choose the desired font type. If it is found in the drop-down list, go to step 9.

![Figure A13.23](image)

5. If the desired font type is not included in the type selector drop-down list. Press Esc. On the Properties palette, click Edit Type.
6. On the Type Properties dialog, select the any predefined font type types. Click duplicate.
7. On the Name dialog, enter the name of the new font type, click OK.
8. On Type Properties, change the parameters to desired values, click OK to finish. For details about formatting the text note, Revit Structure 2011 User's Guide refers.
9. Right click at the location on the drawing area where the text note is to be placed.
10. Enter text, and then click anywhere in the view to finish it.
11. The text note controls remain active so that you can change the note’s position and width, and rotate it by means of using its handles.
Placing a Text Note – With Leader

Purpose:
To place a text note (with leader) into a project.

Prerequisite:
The required arrowhead type has already been added. For detail see Customizing Dimensions Arrowheads.

Steps:
1. Zoom to the location where text notes are to be placed.
2. Click Annotate tab ➤ Text panel ➤ A Text.
3. From the Modify | Place Text ➤ Format panel, select required leader type, leader location and text alignment as follow (or other as appropriate).
4. On the Properties palette, click Edit Type.
5. To select the font type, click the Type Selector. Choose the desired font type, say 2.5mm Arial. If it is found in the drop-down list. Go to step 10.
6. If the desired font type is not included in the type selector drop-down list. Press Esc. On the Properties palette, click Edit Type.

7. On the Type Properties dialog, select the any predefined font type types. Click duplicate.

8. On the Name dialog, enter the name of the new font type, click OK.

9. On Type Properties, change the parameters to desired values, click OK to finish. For details about formatting the text note, Revit Structure 2011 User's Guide refers.

10. Right click at the location on the drawing area where the leader start end to be located. Proceed with right clicks to complete the arrow.

11. Enter text, and then click anywhere in the view to finish it.

12. The text note controls remain active so that you can change the note’s position and width, and rotate it by means of using its handles.
Placing Wall/ Beam Mark

Relevant Annexes in sections related to wall and beam refers.
ANNEX XIV – Excel

Objective

To link Excel file to a Revit project for, say piling schedule, loading schedule…etc.

Notes

1. Revit Structure 2011 and AutoCAD 2011 are used here.
2. Excel file can not link directly to Revit project, but it can link to AutoCAD drawings. Base on this available functions, this guidelines present a method for establishing an indirect link between Excel file and Revit project.

Good Practices

It is advisable to format the table as far as possible in Excel file rather than do it in AutoCAD of Revit.

Linking EXCEL File to AutoCAD Drawing

Steps:
1. Open a new AutoCAD file.
2. Click Insert tab ➤ Linking & Extraction panel ➤ Data Link.
3. In the Data Link Manager dialog, click Create a new Excel Data Link.
4. In the Enter Data Link Name dialog, enter a name for the Excel link. Click OK.

5. In the New Excel Data Link dialog, browse to the Excel file. For Link options, specify the Excel sheet and cell range required. Press Preview button to check the Link options.

6. To expand the New Excel Data Link dialog, if required, press ➔ at the bottom right corner of the dialog. Check the Use Excel formatting option and select Keep table updated to Excel format. Click OK twice to exit.
Adding an EXCEL File link to an AutoCAD Table

Steps:
1. Click Home tab ➤ Annotation panel ➤ Table.
2. In the Insert Table dialog, for the Insert options choose From a data link and click button.
3. In Select a Data Link dialog, click to select a defined data link and Press OK twice to exit.
4. Drag and place the table to a preferred drawing location and
click to finish.

Figure A14.7

5. Exit and save the drawing.

Notes:
1. Single line borders will be assigned automatically to the cells which the border lines have been deleted in the Excel file.
2. Other cell formats specified in Excel will be maintained in the AutoCAD table.
3. AutoCAD can NOT be linked with Excel file with the following format:
   i. file with merged cells;
   ii. Text within a cell is rotated;
   iii. Cells with mixed text height;
4. User can leave the final format touch-up process until the linking of the drawing to Revit completed. It is because not all formats made in AutoCAD can be correctly revealed in Revit especially the visibility of cell border lines, note 1 above refers.

Linking AutoCAD Table to Revit Project

Steps:
1. Open the Revit project.
2. To add a draft view to the project, click View tab ➤ Create panel ➤ Drafting View.
3. On the New Drafting View dialog, input the Name and Scale (1:1 is advised). Click OK to finish.

![Figure A14.8](image)

4. To link AutoCAD drawing to the newly added view, click Insert tab ➤ link panel ➤ Link CAD.
5. In the Link CAD Formats dialog, browse to the AutoCAD containing the Excel table. Select Auto-Detect for Import Unit and click Open.

![Figure A14.9](image)

6. To zoom to the table added, type ZF.
Sizing Linked AutoCAD Table in Revit

Steps:
1. Select the linked AutoCAD table.
2. On the properties palette, click Edit Type.
3. In the Type Properties, change the Scale Factor and click OK.

Splitting Linked Table

Steps:
1. Open the AutoCAD file.
2. To define the header of the linked table, select the top row of the table.
3. In the Properties palette, change Row Style to Header. Press Esc to finish.

4. The font size of the header row may be changed automatically by the software. If it does so, reload the link: Select the table. Click Insert tab ➤ Linking & Extraction panel ➤ Download from Source. Adjust the header row height as necessary.

5. Select the table. In the Properties palette, change both Enabled and Repeat top labels for Table Breaks to Yes.

6. While the table remains selected, drag the Table breaking grip up to the row where the table is to be split. Press Esc to finish.

7. Save and close AutoCAD.
Deleting Unnecessary Cell Border in Revit

Notes:
1. Revit always shows single line borders around cells of linked AutoCAD table even the border lines have been omitted in AutoCAD.
2. Revit cannot reformats the linked AutoCAD table so we cannot remove those redundant borders but cover them with white lines instead.

Steps:
1. Open the Revit file.
2. To add line style, click Manage tab ➤ Settings panel ➤ Additional Settings drop-down ➤ Line Styles.

![Figure A14.16](image)

3. In the Line Styles, click New for Modify Subcategories.

![Figure A14.17](image)

4. In the New Subcategory dialog, input Name and click OK.
5. Change Line Color of the newly added line style to white. Click OK to exit.
6. To draw white to cover up the unnecessary lines on the table, click the Annotation tab ➤ Detail panel ➤ Detail lines.

7. In the ribbon, choose the newly added line style in the Line Styles panel. Use Draw and Modify tools to place the white line over the unnecessary lines. Click Modify to end.

8. Also, users can use similar technique in step 9 to modify the line thickness of other border lines by choosing other available line styles.

---

**Figure A14.19**

**Refreshing the Linked Table**

**Steps:**

1. Modify, save (and close) the Excel file.

2. Open the AutoCAD file. Select the table. Click the Insert tab ➤ Linking & Extraction panel ➤ Download from Source. Save (and close) the AutoCAD drawing.
3. Open the Revit file. Click Manage tab ➤ Manage Projects panel ➤ Manage Links.

4. On the Manage Links dialog, highlight the link and click Reload. Click Confirm to finish.

Figure A14.20