Disclaimer

The copyright of the material published in this [BIM User Guide] (Material) is owned by the Hong Kong Housing Authority unless otherwise stated. Extracts or small parts or portions of the Material may be used, copied, reproduced, reprinted, modified, reviewed or translated for research or other educational purposes provided that the user shall assume the entire risk of using the Material and an acknowledgment of the Hong Kong Housing Authority as the source is expressly stated, and the Hong Kong Housing Authority and its officers, employees, representatives and agents shall in no event be held liable to any person or party for any damages (whether direct or indirect, or incidental or consequential) arising from or in connection with any use of the Material or otherwise. Neither reproduction nor translation of substantial parts or portions of the Material for educational purposes, nor use of the Material for purposes other than educational purposes, shall be permitted without the prior written authorization of the Hong Kong Housing Authority.
Table of Content

1. Introduction
2. Standard Procedure of Starting a project
   - Project start off (Template)
   - Assembly the building (Flat -> Wing -> Storey -> Block – Site (External))
3. Naming Convention for view inside Revit
4. BIM Libraries
5. Material, Colour, Line Style of the libraries
6. Standard Procedure of producing 2D Drawings
7. Exchanging data to Other Application
8. Output in accordance to ICU format
9. Other Reference

Appendix 1 – Folder Structure
Appendix 2 – Drawing Standards – Title Block and Project Template
Appendix 3 – System Requirements
Appendix 4 – Level of details for Revit Models
Appendix 5 – Guidelines to create Building Information Modelling (BIM) models for AAP, P1, SOM & SPC
Appendix 6 – Guidelines to create Building Information Modelling (BIM) models for P2, BC, DDRP1 & DDRP2 submission
Appendix 7 – Guidelines for handling 3D Spatial Data from Lands Department in BIM models
1. Introduction

Development and Construction Division (DCD) of Hong Kong Housing Department (HD) is responsible for

- Monitoring Public Housing Construction Programme
- Monitoring Housing Monitoring Information System
- Commenting on territorial / district / local planning studies and planning standards and guidelines
- Reviewing and formulating strategies and policies as well as preparing and implementing pertinent legislation with regard to construction of public housing
- Formulating and implementing corporate procurement, safety and environmental management strategies

DCD is a multi-disciplinary setup with professionals from Architecture, Structural Engineering, Building Services Engineering, Civil Engineering, Geotechnical Engineering, Quantity Surveying, Landscaping, etc. With the implementation of Building Information Modelling (BIM) in DCD, electronic models would be developed and carried throughout the project lifecycle from feasibility studies, schematic design, details design, analysis, construction and maintenance. Standards and guidelines are important for effective model building, electronic file exchange, data and information compatibility, people communication, not only for in-house staff, but also for our consultants and contractors.

During our development of in-house BIM Standards in year 2008, there was no standards and guidelines widely accepted as the de-facto standards in the industry in Hong Kong. It was prepared based on existing HD CAD standards which has been used, updated and proved to be workable for more than 20 years, also incorporated inputs and best practice from industry. New elements were added in developing this guideline to include additional features provided in BIM which did not exist in two-dimensional (2D) environment. The BIM Standards developed was meant to be software neutral and applicable to any BIM software.

We had removed unnecessary details and retain only essential elements so that make the guideline simple to read and follow. By no mean this guideline is perfect and comprehensive. We wish this could form a basis for continuous improvement as we anticipate that the BIM technology will be changing quickly. We welcome suggestions and expert advice from in-house staff as well as industry practitioners.

Suggestions, comments and other matters related to this document can be written to Mr. David Mak, Senior Manager / Business Information Technology (Construction) (email: davidsk.mak@housingauthority.gov.hk) of Housing Department.
2. **Standard Procedure of Starting a Project**

2.1 **Project Startup**

All projects should follow the procedures shown below in starting a project.

2.1.1 **Setup of Project Team**

The Project Manager and/or Project Architect provides a “Project Narrative” that includes details about the physical characteristics of the project (size, location, etc.), special project needs, the scope of the work, the team makeup, and the phase of the design process. The project BIM coordinator prepares the project “Startup” file(s) which may include special families, colour palettes, the browser organization setup, and other elements.

<table>
<thead>
<tr>
<th>Project Team Member</th>
<th>Responsibility</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Manager / Project / BIM Co-ordinator</td>
<td>Prepares the project “Startup” file(s)\nManages files in CORD area (area for files sharing within the project) – Maintain latest version of models shared (various disciplines) in CORD area\nCrash Checking\nNotify for model updating to team members</td>
</tr>
<tr>
<td>Architectural Users</td>
<td>Create and manage Architectural models</td>
</tr>
<tr>
<td>Building Services Users</td>
<td>Create and manage MEP models</td>
</tr>
<tr>
<td>Structural Engineering Users</td>
<td>Create and manage Structural models</td>
</tr>
<tr>
<td>Landscape users</td>
<td>Create and manage Landscape models</td>
</tr>
<tr>
<td>Civil Engineering Users</td>
<td>Consider to involve in coming future</td>
</tr>
<tr>
<td>Geotechnical Engineering Users</td>
<td>Consider to involve in coming future</td>
</tr>
<tr>
<td>Quality Surveying users</td>
<td>Consider to involve in coming future</td>
</tr>
</tbody>
</table>

2.1.2 **Startup Files**

Projects are started from one of the standard template files and saved to the Model folder. Additional material is copied to the initial file(s) from the various standard “container” files that accompany the template files (typically with the “Transfer Project Standards” command). The initial settings that used to be contained in the standard template files are:

2.1.3 **Adding Levels and Views**

As levels are add to the starter set that came from the template, the corresponding views are added (see View Naming which follows.) The Sheet Discipline # and View Sheet Group properties of views are set so that the Browser Organization setting behaves properly.

2.2 **Level of details for Models (Architectural)**

<table>
<thead>
<tr>
<th>Models for</th>
<th>Level of details</th>
</tr>
</thead>
<tbody>
<tr>
<td>AAP, P1, SOM &amp; SPC</td>
<td>Massing with simplified layouts</td>
</tr>
<tr>
<td>P2 &amp; BC</td>
<td>Detail elevations, Section, layouts &amp; details for critical components / Areas</td>
</tr>
<tr>
<td>DDRP 1 &amp; 2</td>
<td>Details of model equivalent to working drawings (for complex details – using 2D geometry to represent in plan, section or elevation e.g. details of windows)</td>
</tr>
<tr>
<td>ICU</td>
<td>Details of model equivalent to working drawings with special requirement for ICU submission.</td>
</tr>
<tr>
<td>Tender</td>
<td>Details of model equivalent to working drawings (for complex details – using 2D geometry to represent in plan, section or elevation e.g. details of windows)</td>
</tr>
<tr>
<td>--------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Construction</td>
<td>Clash detection by contractor</td>
</tr>
<tr>
<td>Maintenance</td>
<td>As Built model provided by contractor</td>
</tr>
</tbody>
</table>

For details, please refer to Appendix 4, 5, 6

2.3 Setting out for the Site Project

When start-up a site project, the shared coordinates are recommended to locate at the most left of the whole project in round up figure (e.g. 835300E, 821500N = xy 0,0), and the site should sit in positive X & Y coordinates. All created elements and component should locate in the right position and level. (Fig 2.3)

![CAD Project Information Sheet](image)

Fig 2.3
* Build your revit model at or near the position of the elevation marks in the default template with the building oriented orthogonal to your desired printing frame. i.e. use a Project North not True North for your working environment.

For one building on a site:

* Link in a site model or site dwg.
* Move and Rotate the SITE so that it is located correctly relative to the building.
* Acquire the site's coordinates. Now, the site's origin will be the origin of your shared coordinates. The site's Y axis will be True North. The site coordinate values can be arbitrarily large without disturbing Revit's internal calculations.
* You can later open the site model and link in the building using shared location and it will land in the exact position.

For multiple buildings on a site:

* Create a Site project, link in a site dwg, placing the center of the building site near the center of the default view.
* Acquire coordinates from the site.
* Build any site elements, topos, etc.
* Link in building rvts. Move and rotate them so that they are correctly located on the site.
* Publish coordinates to the rvts. Now all models will have the same Shared origin and True North orientations.
* You can now link the site into any of the buildings (the other buildings can be linked in as well) using shared location and it will be in the exact location.

Tips

NEVER import or link a site with large coordinate values Origin to Origin! This may seem correct based on AutoCAD experience, but here to you will be very unhappy in Revit. Refer to Part 1 of Appendix 5
2.4  Assembly the building

File structure for kinked models

An estate is built by linking Architecture, Structure and MEP models. Linking Revit models are primarily intended for linking separate buildings, such as domestic blocks, carpark and site etc.

2.4.1 DON’T create all elements in one single model (file).

2.4.2 Create models in smaller portion/zone e.g. flat, ground floor, typical floor, pagoda, play area, etc. Example of model structure for project Tuen Mun Area 18 (Fig 2.4).

2.4.3 Link up models to form a logical unit e.g. a block (highlighted in blue box in Fig 2.4).

2.4.4 Link up logical units to form the final model of the project e.g. a project (highlighted in green box in Fig 2.4).

![Fig 2.4](Image)
**Concept**

When you link a Revit model into a project, Revit Architecture opens the linked model and keeps it in memory. The more links a project contains, the longer it can take to open.

Linked Revit models are listed in the Revit Links branch of the Project Browser.

It is recommended to use linked models for:

- Separate blocks on a site
- Parts of buildings which are being designed by different design teams or designed for different drawing sets
- Coordination across different disciplines (for example, an architectural model and a structural model)
**Tips on nested linked model**

When you import a Revit model that contains a linked Revit model, links become nested. You can show (or hide) nested linked models in the host model. By default, nested linked models are not visible in the host model.

When a nested link is visible, you can use TAB to select nested link instances and view properties of elements in the nested link, as you can with other linked models. In addition, the Interference Check tool checks for interference in the nested linked models as well as the parent linked model.

Nested links that are visible in the project display in the Revit Links branch of the Project Browser under their parent link. Nested links do not display in the Manage Links dialog.
In later stages of a project, it is generally not recommended to create a single building model with linked models due to the following:

- Limited joining and interaction between elements in the host project and elements in the linked models will prevent elements from cleaning up or joining with elements in linked models.
- Difficulty managing element names, numbers, and identity data between the host project and the linked models; which can result in duplicate names or numbers.
- Separate project standards for the host project and linked models, causing models to become out of sync with each other.
- Maintaining control; in order to do this linked models need to be carefully managed (for example, linked model file names and file paths do not change once files are imported into a host project).

More complex detailing and annotation process; some details and annotations will need to be in the linked model and others will need to be in the host project.
3 Naming Convention for view inside Revit

3.1 View and Sheet Settings
General View Naming Conventions

3.1.1 View Names in the Documents
View names that also occur in the document set as level labels or plan titles are named in accordance with HD CAD Standards and other project concerns. (Generally, these are the same views that are used for annotation although that is not the purpose of the distinction in this section.)

Level names are spelled out as they need to appear in a room schedule (as well as how they will appear in sections and elevations.) Do not begin the level number with leading zeros.

**Naming convention for levels would use:**
- SITE
- GROUND FLOOR
- FIRST FLOOR
- TYPICAL FLOOR
- ROOF

Views that appear in the documents are named by identifying their subject first, and then modified by their level when appropriate:

- FLOOR PLAN – GROUND FLOOR
- CEILING PLAN – GROUND FLOOR
- DETAIL PLAN AT ELEVATOR 1 – GROUND FLOOR
- NORTH – SOUTH BUILDING SECTION
- WALL SECTION 1
- SOUTH ELEVATION

(You could use the Tips below to arrange the sorting of the view according to your needs. **Browser - Views : all** is the default views and views is sorted in alpha-numeric order.

3.1.2 View Name Case
View names that appear in the documentation (level labels or plan titles) are all capitals

All other view names are mixed case.

Users should not rename views that are all capitals unless they intend to make the corresponding change in the documents, and are authorized to do so.

3.1.3 Special Plan Views
Plan views differ in Revit from other views because they can be duplicated (without reproducing their reference mark as is necessary with elevations and sections.) This results in many special-purpose plans that are not placed on sheets.
These views do not typically contain any notation. There are exceptions to this, such as room tags on color fills and export documents, for example.

3.1.4 Color Plans
Color filled plans that will be places on a sheet will typically have a more descriptive title such as “DEPARTMENT – GROUND FLOOR”

Color plan are named with the form:
Color - <modifier>

For example:
Color - GF
Color - GROUND FLOOR Departments

3.1.5 Callout Views
Detail views, including views which are used only as a container for a linked AutoCAD detail, are named with the same general conventions as other views. However since there are often so many of them, and their titles have subtle variations, the use of the Project Browser is even more problematic and the use of the View List more important. (View List is a schedule (list) of all views in a project)

<table>
<thead>
<tr>
<th>View Name</th>
<th>Sheet Number</th>
<th>Sheet Name</th>
<th>Detail Level</th>
<th>Scale Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building Section</td>
<td>A4</td>
<td>Sections</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>Cap Flashing</td>
<td>A5</td>
<td>Details</td>
<td>Fine</td>
<td>4</td>
</tr>
<tr>
<td>Changing Stair</td>
<td>A6</td>
<td>Interiors</td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Cleaftory Pl</td>
<td></td>
<td></td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Cleaftory Pl</td>
<td></td>
<td></td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Computer Co</td>
<td>A5</td>
<td>Interiors</td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Cukbies</td>
<td>A5</td>
<td>Interiors</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>East Elevato</td>
<td>A3</td>
<td>Elevations</td>
<td>Fine</td>
<td>96</td>
</tr>
<tr>
<td>Elevation of F</td>
<td></td>
<td></td>
<td>Fine</td>
<td>8</td>
</tr>
<tr>
<td>Entry Elevato</td>
<td>A3</td>
<td>Elevations</td>
<td>Coarse</td>
<td>96</td>
</tr>
<tr>
<td>Floor Plan</td>
<td>A2</td>
<td>Plans/Schedule</td>
<td>Medium</td>
<td>96</td>
</tr>
<tr>
<td>From Parking</td>
<td>T</td>
<td>Title Sheet</td>
<td>Medium</td>
<td>0</td>
</tr>
<tr>
<td>Half Height</td>
<td>A5</td>
<td>Interiors</td>
<td>Medium</td>
<td>16</td>
</tr>
</tbody>
</table>

This subject has not been fully standardized but the organization system used should be based on Housing CAD standard that governs both the Library naming system as well as the detail sheet number (This helps to organize the details by sheet. It also anticipates that many Revit details will be based on architectural knowledge created from the details)

3.1.6 Sheet naming Convention
Sheet name is closely related to information built inside the title block. When creating new sheet in Revit, user has to choose the appropriate title block from (location?). The sheet name is composed by 2 parts: Number and Name.
Tips for Set up your Browser Organization

You can organize your Views based on this new “View Use” parameter. To do this, go to the “Settings” pulldown again, then choose “Browser Organization…” Name it “Use”, then use the following settings: If you are an A/E firm or you are using Revit MEP, you may also want to add “Discipline” as the first “Group by” field, then “View Use” and “Family and Type”. From now on, you could choose to
**Tips for Set up your Browser Organization**

By default, Revit sorts the level in alpha-numeric order. To display the level according to the actual height, you could create a view with "New", give a name (e.g. Level). Then change the settings as follows. From now on, you could choose "Level" and display the level according to the actual level.
4.1 User can load pre-set libraries from default path. (fig. 4.1)

4.1.1 \housing\divisions\dcd\bim\HD Library

4.1.2 There are several types of libraries

   a) My Library (read write)
   b) HD Common Library (read only) (Under preparation)
   c) HD Grouped Models Library (read only) (Under preparation)
   d) HD Discipline Component Libraries (read only) (Under preparation)
   e) Revit Libraries (read only) (Under preparation)

4.1.3 My Library was used to store user created library components, it may be a custom made use one-time components. If these components could be used for other projects, they should be stored in HD Discipline Component Libraries.

4.1.4 HD Common Library was used to store shared components such as title blocks, annotation symbols, dimension symbols, etc. Most of them would be included in the HD Standard Template (more in Template) and load when users start a new project. In case if users did not start with HD Standard Template, they could load the symbols from this library.

4.1.5 HD Grouped Models Library was also created for storing standard modular flats (e.g. 1P/2P flat, 1B flat, 2B flat etc.), lift core & precast elements etc.

4.1.6 HD Discipline Component Libraries were created for each discipline for storing components frequently used by each disciplines (shown in left menu in the figure 5.1). For example, HD ARCH Library, HD BS Library, HD SE Library.

4.1.7 Revit Library and Revit Detail Library are libraries that come with the software, modified library components should be stored either under discipline specific libraries or users own library (My library)

4.1.8 For library components that could be stored in Discipline Component Libraries, they should be submitted to Standards & Guideline Working Group (SGWG) for checking and publishing.
Fig 4.1
5 Material, Colour, Line Style of the libraries

In AutoCAD object colour line pattern and weight are usually controlled by the layer it is located. In Revit they are based on Category, which could be found under the pull-down menu Setting/Object Styles. (Fig. 5.1). The Object Styles command specifies line weights, line colours, line patterns, hatching patterns and materials (3D rendering) for different categories. It also control subcategories of model objects, annotation objects (e.g. tag, symbols), and imported objects in a project (e.g. AutoCAD file).

![Fig 5.1 Object Styles dialog box]

5.1 Line Weight
You can modify the line weight under the pull down menu Settings > Line Weights
You can control line weights for model lines, perspective lines, and annotation lines. For model lines, you can specify line weight for modelling components, such as doors, windows, and walls, in orthographic views. There are up to 16 model line weights, each of which is defined in mm and can be given a size for each view of different scale. (Fig 5.2).
Line Patterns

Line styles are used to indicate different effects, such as a dashed (------) line for reference planes. When you install and run Revit Architecture, several line styles are included. Each predefined line style has a name that describes either the line (for example, Dash dot), or where Revit Architecture uses the line style (for example, <Sketch> lines). Revit Architecture stores the line styles in the default template.

You can create line styles in the project environment by accessing the pull down menu Settings > Line Styles. (Fig 5.3) Each new line style has a corresponding line pattern, which could be created through the Line Pattern dialog box located under the pull-down menu Setting > Line Pattern (Fig 5.4). You can create new line pattern by defining the length of dash and space.
Fig 5.3

Fig 5.4
5.3 Materials (Surface / Cut Pattern)

Materials define the appearance of elements in the building model. It is similar to the hatching pattern in AutoCAD when it comes to surface or cut pattern in Revit. Revit Architecture provides many materials that you can use, or you can create your own materials.

You can access the Materials dialog by clicking Settings > Materials. Use the left pane of the Materials dialog to find a material. Use the right pane to change properties of the selected material (Fig 5.5). (To conform to ICU drawings submission, please refer to Section 10)

To change the display properties of a material in project views, use the Graphics tab of the Materials dialog. You can change settings that define the way the material displays in shaded views, as well as the way its outer surfaces and cut surfaces display in other views by specifying different pattern under “Surface Pattern” or “Cut Pattern” (You could define your own pattern similar to what you did with AutoCAD)

Render Appearance tab define the material and its properties to be used during the 3D rendering.

![Fig 5.5](image-url)
6 Standard Procedure of producing 2D Drawings

2D drawings (e.g. floor plan, elevations, sections etc) are generated from the 3D models in Revit. To create the drawings set in Revit, you first setup sheets which are much like the paper space (layout) in AutoCAD. You will put title block of different paper size (e.g. A1, A3) in each sheet and then place multiple drawings (views) on each sheet.

Fig 6.1

To add views to a sheet

6.1 Select the Titleblock
Create or open a existing sheet. If you create a new sheet, you have to choose an appropriate title block from the list in the “Select a Titleblock” dialog box. (Fig 6.2). Title block from A0 to A4 and B1 has been already included in the project template.
6.2 Place the view
Drag and drop the view (e.g. floor plan, sections) from the project browser on the left onto the sheet you just created or opened. The views are much like the viewport in AutoCAD, you could move it around or change the scale and title.

6.3 Change the scale
The scale of the individual view could be changed at the view bar at the bottom of the original view. To change the scale within the sheet view, you have to use the “Activate View” command to activate the view first. (Fig 6.3)
6.4 Adding text and dimension
Dimension and Text command could be found in the Basics or Drafting tabs in the Design Bar. Text and dimension are usually created in the original view of floor plan, elevation and section. Placing text in Revit is similar to placing text in AutoCAD in model space. However, in Revit text size and dimension text size are defined in the actual size (e.g. 1.5mm) in the drawing sheet. In other words, text of 1.5mm in A1 sheet will always be 1.5mm no matter what scale of the view you choose.

Just like others families in Revit, text and dimension are stored in type, which could be accessed from the type selector. Different text type represents different text size, font type, colour and weight. (Fig 6.4)

Different way of dimensioning (e.g. linear, angular) could be accessed in the option bar next to right of the type selector. (Fig 6.5) Different dimension setting (e.g. tick mark size, text size, witness line length etc) are stored inside different dimension type. (Fig 6.6)

![Fig 6.4](image1)

![Fig 6.5](image2)
6.5 Linking DWG details to Revit

In the case of referencing some standard drawings and details which are already in AutoCAD format, the common practice is to import or link the AutoCAD drawing into Revit. Details steps are given as follows:

**Step 1: Create Drafting Views for the DWG Files**
For each detail you want to import or link, create and name new drafting views in Autodesk Revit, as shown here. (Fig 6.7)
Step 2: Import or Link the DWG Files

After the drafting view has been created, you either import or link the external file. Open the new drafting view, and on the File menu, click Import/Link ➤ DWG, DXF, DGN. Select the Preserve colors and the Center-to-center options for the best performance. (Fig 6.8)

If you import the file, the data is embedded in the Autodesk Revit project. If you link the files, the result is a smaller Autodesk Revit file that can be further modified in AutoCAD. Autodesk Revit automatically gets the most current version of the linked file whenever the project is opened or the link is reloaded. It is best to use Link if you plan to develop details in AutoCAD. Import is recommended if you plan to modify your details using Autodesk Revit.
Step 3: Place the Details on a Sheet
After arranging the individual detail files in drafting views, open an existing sheet or create a new sheet for the details. On the View menu, click New ➤ Sheet. In the Select a Titleblock dialog box, select the desired titleblock.

After you have created the sheet, place the drafting views. Place drafting views in the same way you would place any view created in Autodesk Revit. Either drag the desired views from the Project Browser onto the sheet or, on the View menu, click New ➤ Add View, and then select the desired view. (Fig 6.9)
Place drafting views in the same way you would place any view created in Autodesk Revit. After you have placed the view, the DWG details are part of your Autodesk Revit set. (Fig 6.10)
7 Exchanging data to Other Application

7.1 AutoCAD (Revit to AutoCAD – Layer standards)
Revit Architecture supports exporting to CAD (DWG and DXF), DWG (drawing) format is supported by AutoCAD 2009 and other CAD applications. (Fig 7.1)

You can export either views or sheets, depending on the scope of work to be done in AutoCAD, as well as the progress of construction documentation in Autodesk Revit. Exporting a view creates a DWG or DXF file of the currently selected Autodesk Revit view. All external data linked to the view will be embedded as a block in DWG or DXF format. Use this method when you intend to annotate only selected views in AutoCAD.

If you use the Export command while in a 3D view, Revit Architecture exports the actual 3D model, not a 2D representation of the model. Exporting in 3D ignores all view settings, including hidden line mode. To export a 2D representation of the 3D model, add the 3D view to a sheet and export the sheet view. You can then open a 2D version of the view in AutoCAD 2009.

Exporting an entire sheet from Autodesk Revit produces a set of DWG or DXF files. One file contains sheet information (borders, title block) with a viewport for each view. Each Autodesk Revit view becomes an individual file referenced into the sheet file and displayed in the appropriate viewport. All files are located in the same directory to facilitate tracking and management.

![Fig 7.1](image-url)
7.2 Data Export Options

The following options are available in the Export dialog box:

Range: Select either the current view or a set of views/sheets. The latter facilitates a batch like export of a range of views.

Option (Layer settings):
In the Export Layers dialog box, categories and subcategories of Autodesk Revit host components are mapped to a layer name and color number for use in a DWG or DXF file, using settings specified in special text files in the Revit \ Data directory. By default, Autodesk Revit uses the last-specified export layer standard. You can select from these or create custom standards. (Fig 7.2)

![Export Layers dialog box](Fig 7.2)

To preserve information about a project, Revit Architecture automatically maps categories and subcategories to preconfigured layer names. These layers are used by AutoCAD 2009 and other applications. Before exporting a Revit Architecture project, you may want to change the mappings to the desired layer names.

7.2.1 Export Revit model to 3ds Max files

There is no direct way to export 3D model into MAX file through the RVT format. However, you could either export to DWG format or FBX format. For DWG format, use the same procedure as exporting AutoCAD DWG format. Once completed, you could either link or import the DWG file inside 3ds Max environment. (You have to make the 3D view as the...
current view)

The procedure of export the 3D model as FBX format is similar, you have to bring up a 3D view. Just give a output name in the File name/prefix field. The main difference between these 2 ways is that: i) the file size of the exported DWG format is much smaller than that of FBX format. ii) using FBX format could retain most of the material properties originally defined in Revit, which in turn give similar result when rendering in 3ds Max. iii) DWG format could be linked or imported in 3ds Max while FBX format could only be imported.

7.2.2 Export Revit to NavisWorks files

NavisWorks is an Autodesk software which are used to visualize and simulate complex project for real-time review and analysis

Your PC should have the NavisWorks installed (not the NavisWorks Freedom viewer) in order to see this option. You could bring up the export dialog box from pull-down menu Tools/External Tools/NavisWorks 2009. (You could change the default settings by choosing “NavisWorks settings …”

7.2.3 Export Revit to STL files (for 3D printing)

TL is a file format native to stereo lithography. The file format is supported by many 3D printers. As such, it is often used for rapid prototyping and computer-aided manufacturing.

Your PC should have the STL exporter installed in order to see this option. You could bring up the export dialog box from pull-down menu Tools/External Tools/Export STL. You could choose either option Binary or ASCII. Then choose the folder and give the output filename.

7.2.4 Export Revit to IFC files

The Industry Foundation Classes (IFC) file format was developed by the International Alliance of Interoperability (IAI). IFC provides an interoperability solution between different software applications. The format has established, international standards to import and export building objects and their properties

Before exporting a Revit Architecture project to IFC, you may need to map generic family instances to IFC containers (element types). You do this by creating a new IFC mapping file or editing an existing one. To load and modify an IFC mapping file, click File menu>Import/Export Settings>IFC Options > Export Options

7.2.5 Publish to 2D/3D DWF files

The Design Web Format™ (DWF™) is the Autodesk method of publishing design data. It offers an alternative to publishing to PDF (Portable Document Format). Users can choose to out either 2D files or 3D DWF or both from Files/Publish DWF. DWF files are significantly smaller than the original Revit (RVT) files, making them easy to send by electronic mail or
post to a, making them easy to send by electronic mail or post to a web site. To view the DWF files, user can use viewing and markup tools “Design Review”.

7.2.6 Import/Link of CAD Formats (i.e. AutoCAD files).

1. Click File menu > Import/Link > CAD Formats.
2. In the Import/Link dialog, navigate to the folder that contains the file to import or link.

Tip: Make sure you import the geometric data needed for the Revit Architecture capability that you plan to use. For more information, see Suitability of Imported Geometry.

3. Select the file.
4. Select Link if you want to link the file (instead of import it).
5. Specify the import options. See Import Options for CAD Formats and Revit Models.
6. Click Open.

7.2.7 Import of Land Survey data for Toposurface creation.

Refer to Appendix 7

7.2.8 Import/Link of IFC files

Revit Architecture provides Industry Foundation Classes (IFC) import based on the latest International Alliance for Interoperability (IAI) IFC 2x3 data exchange standard. (If you import a file that uses an earlier standard [IFC 2x or 2x2], Revit Architecture supports the format and imports it properly.)

When you import an IFC file, Revit Architecture creates a new file based on the default template. The default template could be accessed through File menu>Import/Export Settings>IFC Options > Import Options

7.2.9 Import/Link of Images files

You can import or link raster images to a Revit Architecture project to use as background images or as visual aids needed during the creation of a model. Revit Architecture supports the following image file types: BMP (bitmap), GIF, JPEG, JPG, PNG (portable network graphics), and TIFF. By default, images are imported behind the model and annotation symbols; however, you can change the display order. You can import images into 2D views only. An example is to include a corporate logo or image in a title block.
Tips: Implications of Importing vs. Linking for Xrefs

Suppose you use AutoCAD to generate a DWG file that contains external references (xrefs). When you import or link the DWG file, Revit Architecture displays the geometry from the nested xrefs. The decision to import or link a file to a Revit project affects what you can do with the xref information:

If you import the file, you can explode the nested xrefs to Revit elements. However, if the xref file is updated after the import, Revit Architecture will not automatically reflect changes to the xref file.
If you link the file, Revit Architecture automatically updates the geometry to reflect changes to the xref files. However, you cannot explode the nested xrefs to Revit elements.
Chapter 8: Output in accordance to ICU format

Revit provides a way to switch ordinary working drawings to the way that it is required to be presented for ICU drawing submission. Instead of defining the material according to Section 7, “Filters” has been setup to achieve this colour and presentation conversion.

Different filters have been created according to the ICU standards as shown in Fig. 8.1. For instance, “ICU Concrete” filter was defined with a colour of Green and will overwrite any concrete structure (e.g. wall, columns etc) with the parameter “description” with value of “Concrete”. (Fig. 8.2).

To simplify the whole overwritten process, an ICU submission template has been created for this colour conversion in each project for different objects colour.

To apply the template to a specific view:

1) Make the view you are going to change colour as the current view (colour overwritten process is view dependent)

2) Click View menu > Apply View Template …

3) Select “ICU Submission Section” from the Names list on the left. Then press the Apply button to finish the process.
To restore the view from ICU presentation to normal colour

1. Make the view you are going to turn off the filter overwritten effect as the current view (this process is view dependent)

2. Click View menu > Apply View Template …

3. Select Original View Plan (or Section) from the Names list on the left. Then press the Apply button to finish the process

To create additional ICU colour filter

1. Setup the object type parameters “Description” with the specific value (e.g. Brick)

2. Click Settings menu > Filters. In the Filters dialog box, use “New” to create a filter.

3. Select one or more categories to be included in the filter from the middle column.

4. Create the Filter Rules by defining the “Filter by:” field. In this case, Description.

5. Then continue to define the value but choose “equal” in the 2nd filed and fill in any necessary value in the 3rd field (e.g. Brick)
9 Other Reference

9.1 User can retrieve more information for Revit from the following web site:-

  revit.com.hk
  www.revitcity.com
  usa.autodesk.com
Appendix 1

All elements in Revit Architecture are family based. The term, family, describes a concept used throughout Revit Architecture to help you to manage your data and to make changes easily. Each family element can have multiple types defined within it, each with a different size, shape, material set, or other parameter variables as designed by the family creator. Changes to a family type definition propagate through a project and are automatically reflected in every instance of that family type within the project. This keeps objects coordinated and saves you the time and effort of manually keeping components, and schedules, up to date.

To help users to reuse these families throughout the project at different stage, families are categorized and stored under 2 main groups, namely “Group Model” and “Component Model”. “Group Model” are those Revit objects which are assembly from standard Revit families. They are usually large in size and exist in the folder structure as *.rvt files. Flat types and precast façade are some of the examples of “Group Model”. On the other hand, “Component Models” are standard Revit families are grouped and stored according to its functional type and its material in a project. Doors and windows are the 2 most frequently used “Component Models” in the project.

Group Model

3 Levels of folder structures are used to sort the “Group Models”. The 1st level is the folder name of the main type. (e.g. Flat type, Precast Element, Bathroom). The 2nd level is the folder names and filenames of the different variation, sub-category of the type specified in the 1st level (e.g. 1P/2P, machine room). An example of the folder structure is given below.

<table>
<thead>
<tr>
<th>First Level</th>
<th>Second Level</th>
<th>Third Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lift Core</td>
<td>4 lift Option</td>
<td></td>
</tr>
<tr>
<td></td>
<td>6 lift Option 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>6 lift Option 2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Machine Room</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Rope Inspection Room</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Lift Pit</td>
<td></td>
</tr>
<tr>
<td>Flat Type</td>
<td>1P/2P (Option 1)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>1P/2P (Option 2)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2P/3P (Option 1)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>2P/3P (Option 2)</td>
<td></td>
</tr>
<tr>
<td>Bathroom</td>
<td>Small Flat</td>
<td>1P/2P Flat</td>
</tr>
<tr>
<td></td>
<td></td>
<td>2P/3P Flat</td>
</tr>
<tr>
<td></td>
<td>Family Flat (1B &amp; 2B)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Disabled</td>
<td></td>
</tr>
<tr>
<td>Precast Element</td>
<td>Facade</td>
<td>Facade (1P/2P ) Type 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Facade (2P/3P ) Type 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Facade (1B / 2B ) Type 1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Facade (1B / 2B ) Type 2</td>
</tr>
</tbody>
</table>
Component Model

4 levels of folders structure are used to describe and group the Revit standard families. The 1\textsuperscript{st} 3 levels are main categories or sub-categories of the families while the 4\textsuperscript{th} level are the actually Revit families appear as *.rfa file. (e.g. HD_DR_Bath_R01). An example of the folder structure is given below

<table>
<thead>
<tr>
<th>First Level</th>
<th>Second Level</th>
<th>Third Level</th>
<th>Fourth Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bath Room/Kitchen</td>
<td>Accessories</td>
<td>Basin</td>
<td>Basin - wall mounted.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Basin - wall mounted - Small size.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Basin - wall mounted - corner type.rfa</td>
</tr>
<tr>
<td></td>
<td>Shower</td>
<td></td>
<td>Shower Tray.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Sunken Shower-in-situ.rfa</td>
</tr>
<tr>
<td></td>
<td>shower grating</td>
<td></td>
<td>WC - close couple with dual flush.rfa</td>
</tr>
<tr>
<td></td>
<td>Toilet paper holder</td>
<td></td>
<td>Holder- Surface mounted.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Holder- Semi-recess.rfa</td>
</tr>
<tr>
<td></td>
<td>Drying rod</td>
<td></td>
<td>Drying rod - Plastic coated - straight.rfa</td>
</tr>
<tr>
<td></td>
<td>Laundry Rack</td>
<td></td>
<td>Rack - Wall mounted with 2 drying rods.rfa</td>
</tr>
<tr>
<td></td>
<td>Mixer</td>
<td></td>
<td>Mixer - Wall mounted for shower.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Mixer - Deck mounted for kitchen sink.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Mixer - basin with pop-up waste.rfa</td>
</tr>
<tr>
<td></td>
<td>Door</td>
<td>Balance Flue</td>
<td>Opening for gas heater.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Swing</td>
<td>Single leaf- flat entrance.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Single leaf - Kitchen.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Single leaf - exit staircase.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Single leaf - refuse room.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Single leaf - bathroom.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Single leaf - services room.rfa</td>
</tr>
<tr>
<td></td>
<td>PVC Door</td>
<td>Folding</td>
<td>Double leaves - Transformer room.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Swing</td>
<td>Double leaves - switch room.rfa</td>
</tr>
<tr>
<td></td>
<td>Metal Door</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Window / louvre</td>
<td>Windows</td>
<td>Kitchen</td>
<td>Double side hung window.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bathroom</td>
<td>3-Levels top hung window.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Living/dining room</td>
<td>Fixed type.rfa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Typical floor lobby</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Typical</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Window grille</td>
<td>Side hung window</td>
<td></td>
</tr>
</tbody>
</table>
Appendix 2

Project Template
Project template provides initial conditions for a project. Users are recommended to start an Revit project from the standard project template. These templates are prepared from HD standard drawing paper sizes. The following items are the basic initial settings of a template:

Dimension & Leader Styles (1:1)
- Basic families (e.g. Basic Wall: HD_Conc_100mm_R01)
- View Template
- Fill patterns and View scales
- Line Weights and Line styles
- Title Block, Logo and its Attribute
- Units and its Precision

HD Standard Drawing Paper Size
Existing drawing formats used are in size of A0, A1, A2, A3, A4 & B1. The dimension of drawing sheets are shown as below:

A0 - 841 x 1189mm
A1 - 594 x 841mm
A2 - 420 x 594mm
A3 - 297 x 420mm
A4 - 210 x 297mm
B1 - 707 x 1000mm

Size of Drawing Sheets
Layout of the Drawing Sheets

Title Panel

If you created a title block using another CAD application, you can import it into Revit Architecture. Some text in the imported title block may reflect information that is specific to the project or sheet. Replace this text with Revit parameters so that the information can update automatically.

To add text to Title Block, select the title block first. Then the text or “question mark” in blue colour could be edited. Another way is to fill in the text by using right click > View Properties of the Sheet.
Presentation style

Line weight
You can control line weights for model lines, perspective lines, and annotation lines.

For model lines, you can specify line weight for modeling components, such as doors, windows, and walls, in orthographic views. Line weight is dependent on the scale of the view.

For perspective lines, you can specify line weights for modeling components in perspective views. You may want to apply different line styles and line weights using the Linework tool.

For annotation lines, you can control the line weight of annotation objects, such as section lines and dimension lines. The weights of annotation symbols are not dependent on the scale of the design.
Appendix 3

System Requirements

Software requirements: Revit Architectural 2009, Revit MEP 2009 and Revit Structure 2009

4.1 Recommended hardware requirements for users working on family creation, standard flat, one single floor

- Intel® Pentium® 4, 3GHz, or equivalent AMD Athlon® processor
- Microsoft® Windows Vista™ Enterprise, Business, Ultimate, or Home Premium; Windows® XP Professional, Home Edition, or Tablet PC Edition (SP1 or later); Windows® 2000 (SP4)
- 1 GB RAM
- 3 GB free disk space
- Dedicated video card with 256MB memory
- 1024 x 768 monitor and display adapter capable of 24-bit color
- Internet connection for license registration
- Two-button mouse with scroll wheel
- Microsoft® Internet Explorer® 6.0 or later

4.2 Recommended hardware requirements for users working on master / combined models, and rendering.

- Intel Core® 2 Duo 2.40 GHz, or equivalent AMD Athlon processor
- Windows XP Professional (SP2 or later)
- 4 GB RAM
- 5 GB free disk space
- 1280x1024 monitor
- Dedicated video card with hardware support for OpenGL® spec 1.3 or later
- Internet connection for license registration
- Two-button mouse with scroll wheel
- Microsoft® Internet Explorer® 6.0 or later
Appendix 4

Level of details for Revit Models

LD0 – Massing blocks
LD1 – Model without internal partitions (for generating elevations)
LD2 – Model with internal partitions but no details (for generating sections)
LD3 – Model with all internal details (for generating working drawings)

1. Level of detail 0 (LD0)

1.1 Massing of building blocks

Fig. 1.1a (LD0)

Fig. 1.1b (LD0)
Fig. 1.1c (LD0)

Fig. 1.1d (LD0)

Fig. 1.1e (LD0)

2 Level of detail 1 (LD1)
2.1 Standard Modular Flats without all internal partitions and fittings, for creating elevations of building block.

2.1.1 To compose LD1 modular flats to form the typical floor plan. For detail elevations of the whole building block, we need to trim down the model size (delete all internal partitions, slabs and facilities) to avoid hang-up in the application.
2.1.2 To compose GF, 1F, TF and Roof to generate elevations of the whole block.
3. Level of detail 2 (LD2)

3.1 Standard Modular Flats with minimum internal partitions and fittings, for creating sections of building block.

Fig. 3.1 (LD2)

3.1.1 To compose LD2 modular to form the typical floor plan. For creating sections for the whole block.

Fig. 3.1.1a
3.1.2 To compose GF, 1F, TF and Roof to generate sections of the whole block.
4. Level of detail 3 (LD3) :- For exporting working drawings and details for single flat or floor.
Fig. 4.1c
5. **Level of details for BIM project (Architectural)**

<table>
<thead>
<tr>
<th>Stage</th>
<th>Drawing Required</th>
<th>Level of details (Revit model)</th>
</tr>
</thead>
</table>
| Architectural Assessment Panel (AAP)       | ● Sketch Site Layout Plan  
● Sketch Typical Floor Plan for Flat mixing  
● Sketch Floor Plan of Facilities  
● Schematic Elevations                  | ● To compose simply modular flats to form the typical floor plan (LD 2)  
● Massing for building blocks (LD 0)    |
| Project Design Review Committee (P1)       | ● Site Layout Plan  
● Typical Floor Plan (domestic blocks)  
● Floor Plan of Facilities  
● Schematic Elevations                  | ● To compose simply modular flats to form the typical floor plan (LD 2)  
● Massing for building blocks (LD 0)    |
| Senior Officer Meeting (SOM)               | ● Site Layout Plan  
If with matter arising, same as P1 (Submission to Town Planning)                  |                                                                                              |
| Strategic Planning Committee (SPC)         | Same as P1 (Submission to Town Planning)                                        |                                                                                              |
| Project Design Review Committee (P2)       | ● Site Layout Plan  
● All Floor Plan of domestic blocks (i.e. Ground Floor, First Floor, Typical Floor and Roof)  
● Flats Layout with furniture  
● All Floor Plan of Facilities  
● Detail Elevations                  | ● To compose simply modular flats to form the typical floor plan (LD 2)  
● Create simply Revit model (without internal details) for all buildings (LD 2)  
● To compose all Revit models (simply – without internal details) to form the project model  
● For elevations:- to composite standard modular flats (LD 1)  
● For sections:- to composite standard modular flats (LD 2) |
| Building Committee (BC)                    |                                                                                  |                                                                                              |
| Detailed Design Review Panel (DDRP 1)      | ● Site Layout Plan  
● All Floor Plan of domestic blocks (i.e. Ground Floor, First Floor, Typical Floor and Roof)  
● Flats Layout with furniture  
● All Floor Plan of Facilities  
● Detail Elevations                  | ● To compose detail modular flats to form the typical floor plan (LD 3)  
● Create detail Revit model for all buildings (LD 3)  
● Export 2D drawings from Revit  
● Touch-up 2D drawings in AutoCAD (if required)  
● Create complicated details in AutoCAD  
● To compose all Revit models (simply – without internal details) to form the project model  
● For elevations:- to composite standard modular flats (LD 1) |
<p>| Detailed Design Review Panel (DDRP 2)      |                                                                                  |                                                                                              |
| Tender                                     |                                                                                  |                                                                                              |</p>
<table>
<thead>
<tr>
<th>Stage</th>
<th>Drawing Required</th>
<th>Level of details (Revit model)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>● For sections:- to composite standard modular flats (LD 2)</td>
</tr>
<tr>
<td>Submission to ICU</td>
<td>● Plans, sections, elevations and calculation</td>
<td>● Export 2D drawing with ICU requirements form Revit models&lt;br&gt;● Touch-up 2D drawings in AutoCAD (if required)</td>
</tr>
<tr>
<td>Tender Committee (TC)</td>
<td>● Site Layout Plan</td>
<td></td>
</tr>
<tr>
<td>Contract / Construction</td>
<td>● Drawings form HA (site instruction from various disciplines)&lt;br&gt;● Shop drawings from NSC</td>
<td>● Updating the Revit models during construction period (LD 3)</td>
</tr>
<tr>
<td>As Built</td>
<td>● As built drawings</td>
<td>● Updating the Revit models to as built and handover to HA (EMD) (LD 3)</td>
</tr>
</tbody>
</table>